0

I'm working on a Libre Office Writer Document where I want to be able to use multiple languages. 10 % of the document are in language X and 90 % are written in language Y. So I set my Writer Language to Language Y and start the spellchecker. Naturally all the words in language X are marked red. So I do 'Ignore All' for each of those words. But as soon as I reload the document (after saving) Writer again marks those words with a red line. What am I doing wrong?

2
  • Why not simply split the document in two, by language? Assuming they're not intertwined...
    – Hannu
    Jul 1 '20 at 16:56
  • The point of the question is my assumption, that the spell check seems to be obsolete. The same problem would happen in a single languge document. Jul 1 '20 at 18:21
1

I'm unsure if you want to completly disable the spell check. It is an odd document and yes there are problems with persisting the spelling vocabulary.

What you can do is choose the Base Language for the spelling check which looks like you know how to do. You can then, by going to Tools -> Options -> Language Settings -> Writing Aids, under user-defined dictionaries you can add your secondary language.

Then, what you do is, as you write, whenever you have the need to write something in the secondary language, once you have typed it, you can select the words with your mouse and leaving them selected you can go over to Tools -> Language -> For Selection and you should have a list of languages to choose from and your secondary language should be there.

This will tell the document that the selected piece of text is meant to be written in this other language and the spelling check will behave accordingly, plus this will persist.

If you reopen the document this will persist, this is assuming that you save it a .odt format, I'm not sure which formats will work with this because that information that persist I beleive would be saved in the contents of the file, so if you were to for example save it as a pure .txt type file, where there is close to no Meta-information within the file's content, this will likely not work, but I can't say I have tested different formats.

If you instead wish to disable the spellchecker for some reason to make things less frustrating that can be gone through:

Tools -> Options -> Language Settings -> Writing Aids

You can disable all of them or as required, you should also check the "live spell check" settings under Autocorrection, called While writing.

At least that way you can write in peace and when you hit a milestone you can enable it again and double check instead of contantly be worrying about that, but the first method is probably the one I would go for.

Hope this is helpful :)

2
  • Thanks that sounds like a good solution. Still I m wondering whether it is possible to tell writer not to double check things that you marked with "Ignore Once" or "Ignore All". Jul 2 '20 at 15:44
  • Hmm not sure, I might be wrong but to me it sounds that is functionanily of the spell checker itself on the writer Application, not on the document, so it wouldn't make sense for that to persist, that function is really just meant be used while you are editing in a short term, not to persist on reopening, that would require additonal meta data to be saved on the document itself to prevent thos ignores to persist (even if they could) for every document. Jul 3 '20 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.