6

I'm a Zoom host, using Windows 10 Home on a laptop. Sometimes my participants complain about seeing solid gray rectangles on their screen. This happens when I share a process that is showing an image or video full screen. These boxes could be caused by various windows on my computer: the two rectangular Zoom meeting control rectangles, the Zoom Participants box, the Zoom Chat box, or other apps such as file explorer or browser. When I share a full screen image or video, I want my participants to see only that, not additional overlaying gray boxes. Is there a setting for this? If not, when are the gray boxes shown and when are then not shown? Note: web searches show no information about gray boxes or rectangles caused by Zoom.

2
  • 1
    Some screenshots would help to figure out what is going on. Is only the other end seeing the grey boxes? If so the problem may have nothing to do with you ...
    – DavidPostill
    Jul 2 '20 at 15:36
  • A proposed edit would add this link: support.zoom.us/hc/en-us/articles/… . While this link may be helpful for users of NVIDIA video cards only, it solves a different problem (a dark screen). The link should have been made in a comment, not an answer edit. Jan 23 at 10:47
4

I figured it out myself, with some experimentation, running as host and participant in the same meeting. The solid dark gray boxes are clearly a security mechanism by Zoom to prevent participants from seeing other windows on top of the shared window.

Why should participants be able to see other windows, you ask? Well, it's simple and complicated at the same time. Instead of simply sending the video being shown directly to the participants, Zoom intercepts the hardware to capture the data as it is being displayed. So you see the topmost shared window AND any windows that are on top of it! Graying out the window prevents participants from seeing whatever the host is doing, for security.

So the solution appears to be pretty simple: just turn OFF the "optimize for showing video" option. Then Zoom simply sends the shared window, again and again (at 6 to 30 frames per second, depending on source and destination bandwidth) to the participants and ignores other windows. In fact, with Optimization off, you can even minimize all windows and/or return to the desktop, and the participants continue to see the shared window only.

For the Zoom meetings I host, I want the best experience for my participants, so I set up muting and other options the way I want, then I show the video in a video player, share the player output, and optimize it. I make sure that all other windows are never displayed on top of the video on my screen while the video is running, and I keep the cursor at the extreme lower right so it is not seen. I avoid any use of the cursor or of Zoom features while I am playing a video. This works perfectly for me, because we don't use chat or other features when playing videos.

2

I present media content every week. My approach to avoiding gray rectangles and making the user experience relatively seamless is two-fold.

  1. Show media using PowerPoint if possible. When showing images and video, I almost always do so as part of a PowerPoint presentation. Using PowerPoint animations, I can control exactly what the audience sees in Slideshow mode without my audience ever having to see the player itself nor my mouse clicking on player controls, for example. I insert each image or video using the Link-to-File insertion option (keeping media from getting stored within the PowerPoint file itself and making the file size huge). For a video, I go to the Playback ribbon and set the Start option to Automatically and usually check the Play Full Screen box. (If I have other content showing on the screen, such as an overlay title in a text box, then I just manually size the video to fit the slide and don't check the Play Full Screen box, as Full Screen mode will bring the video to the front and hide all other content.) When I advance to the slide, the video automatically starts playing.

  2. Use a second monitor. If you can attach a second monitor to your computer and extend your desktop to it, avoiding gray boxes gets much easier. I have Zoom and everything else playing in my main screen, so that's where notifications and such will pop up. I play the PowerPoint slideshow on the second monitor in full-screen mode, and typically start the slideshow before the call. When it's time to share, I select the PowerPoint slideshow as what I'll be sharing, and optimize video and share system sound. With any other apps appearing only on the first monitor, no gray boxes ever appear over the slideshow content on the second monitor.

1
  • 1
    This is a great answer! In my case, I just want to show fullscreen videos. So I download all videos, patch them together with title images using the free OpenShot video editor, then share my video player during our meetings using Optimize mode. I keep the mouse cursor at the far lower right so it disappears and never touch the keyboard or mouse while the video is playing. Using this mode can benefit from a co-host to make sure everyone stays muted,. etc. Dec 5 '20 at 22:07
1

I am not a developer, but this issue has been plaguing us as we run a video for participants but also need to monitor the chats and participant windows. The only people who can see the issue are participants. The host sees their normal windows which tend to be persistent and pinned on top of the other zoom content. Normally these windows are simply hidden entirely from the view of the participants during other screen share modes with video optimization turned off. No placeholder gray boxes or anything.

Turning off the optimization is a workaround and not a solution as it leads to syncing issues with the audio and video. That workaround may be fine for others, but it does't work for us and doesn't seem to be an intended solution as it is only a problem on the Windows 10 platform as far as my Google searches have revealed.

Our workaround has been to have the host log in on a second device and monitor the chat and participant windows from there. We can hide all of the zoom chat/participant windows and hide the floating settings window.

This is not happening on our Mac OS devices. Just the Windows 10. It doesn't seem to be a feature. It seems to be a bug or an implementation issue on Windows 10.

5
  • This is interesting. Exactly how does having a second device login to monitor the chat help you to hide the solid gray boxes? Please explain, as it isn't obvious to me, thanks. Jul 7 '20 at 19:16
  • David, we hide the boxes on the device using the screen share using the zoom options and then on a second device, log in a second time on the same account and monitor the chat and participant windows from there.
    – Ryan
    Jul 8 '20 at 13:28
  • Ryan, just to confirm, you're agreeing with my answer above that the key is turning off the "optimization for fullscreen video" checkbox unless we are willing to keep the screen absolutely free of other windows? Jul 9 '20 at 14:23
  • Your answer is not a solution because it requires a second person to assist the host, ideally sharing the hosting role so administrative/security actions can be done. For many meetings, no such second person is available. My answer at least eliminates the gray boxes in those cases where we don't need the video optimization feature. Jul 15 '20 at 9:50
  • 1
    In the latest Zoom version, 5.5.2, the issue now also appears in macOS! Feb 14 at 10:20
1

We've been running Zoom meetings for about 3 months now, we encountered those boxes several times and one of the best solutions we found to get rid of them was the same as Ryan's solution, which is to share screen from the laptop and control the participants from another device (smart phone).enter image description here

-1

Read the "Advanced share screen options" setting on this page: https://support.zoom.us/hc/en-us/articles/360037870291-Advanced-desktop-client-settings

There is an option to "Share selected app window only" that you can turn on. And there are also screen capture modes that "capture with window filtering" which claims to not show windows from the Zoom client.

1
  • Thank you for your suggestion. However, when optimizing video, the entire screen is sent to your Zoom meeting. So any Zoom or other windows that are displayed on top of the screen will be sent as gray boxes to your participants. You either have to keep ONLY the video on the screen, or don't optimize video. Nov 5 '20 at 13:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.