Nota Bene: Not a duplicate! I've checked the following questions and didn't find the working solution.

Nota Bene 2: I've got a lot more details. Check them in the bottom of the question!


Windows 10: Windows could not prepare the computer to boot into the next phase of installation. To install windows, restart the installation - Answer isn't valid for me, as I don't have ANY OS on my laptop currently.

Can't install windows after linux - The problem is a bit similar (I also had Linux before), but not Windows 7 or anything. Also, it even doesn't have an answer; the comments didn't help as I used Media Creation Tool.

Why does Windows 10 fail to install on UEFI/GPT laptop? - Didn't help as I have 2 drives and my USB. Formatting in FAT32 brings me back to NTFS for no reason.

Windows 10 fails to install to fresh ssd - No answers, comments didn't help as well.

'Windows could not prepare the computer to...' error while installing any windows (7/8.1/10) - Again, my USB is the only EFI bootable drive I have.

And to the problem:

I use MediaCreationTool2004.exe to create a bootable USB drive, straight from Microsoft site. My EFI sees the USB (By the way, my EFI doesn't have a GUI); I select it and boot. Everything goes fine before the literal finish of the installation. It just says Windows could not prepare the computer to boot into the next phase of the installation. Restart and try again.

My laptop OS hierarchy:

  1. Windows 10 x64
  2. Windows 10 x64 once again after me formatting C: for no reason
  3. Ubuntu
  4. Multiboot (Ubuntu, Windows 10 x64)
  5. Kali Linux
  6. Zorin OS
  7. Ubuntu
  8. Linux Mint
  9. Tried to install Windows 8 x64 but didn't succeed (same error)
  10. Tried to install Windows 8.1 x64 but same error
  11. Tried to install Windows 10 x64 but didn't succeed (same error) (current)

Very current: No OS

What've I tried:

  1. Removing each partition when installing but the installation failed instantly (after copying the files)
  2. Removing each partition through diskpart before even installing, which of course failed as well
  3. Not removing the partitions, just formatting the main partition to install but it failed on the last step.
  4. Going to "Repair the system" ---> Delete updates ---> Delete the last update. Outputs "An error occurred..."
  5. Removing literally everything from the laptop I could remove (except for the USB) (mouse, patch cable, charger). Nothing changed, the same error as in the 3rd.
  6. Going to "Repair the system" ---> cmd ---> Using the diskpart and formatting directly from here. Nothing changed.
  7. Cleaning volumes - didn't help, nothing changed.

Also after some time, diskpart started saying Drive not selected. when trying to format C:<br/>
I have no idea what to do.

More data:

Laptop - Digma
CPU - Intel(R) Atom(TM) x5-Z8350 CPU @ 1.44GHz
RAM - 2048 MB DDR3
Windows 10: was licensed when it was on my laptop

The details you came for:


Using MediaCreationTool2004.exe with Windows 10, Russian, x64 settings
Using MediaCreationTool2004.exe with Windows 10, Russian, x86 settings
Using Rufus 3.11.1678 with GPT, UEFI (non-CSM), FAT32, 4096, x64 settings
Using Rufus 3.11.1678 with GPT, UEFI (non-CSM), FAT32, 4096, x86 settings


My EFI doesn't see the NTFS-formatted USB for some reason
My USB is 8 GB

  • There will be installation Log files on the drive you chose to install to, review those for possible clues as to what went wrong/
    – Moab
    Jul 3, 2020 at 14:12

7 Answers 7


For me the issue was that i had one EFI system partition existing and the installer was creating a new one. I have marked my USB FAT partition as an EFI System partition and it seemed to have gotten confused. Marking the FAT partition as a "Windows Basic Data" GUID seems to have fixed it.


Looks like I've found the solution!

  1. You should create the bootable USB using WinSetupFromUSB 1.9 with these steps:

    1. Insert the USB
    2. Format the USB using diskpart (NOT QUICK, FAT32)
    3. Delete each partition from the USB
    4. Using WinSetupFromUsb, create the USB
  1. Plug the USB into your laptop or whatever it is
  2. Remove everything plugged except for the setup USB (charger, patch cable, mouse (used touchpad))
  3. Before installing, click Shift+F10.
  4. Type diskpart
  5. Type lis dis. For me, it outputted, that I have 3 disks (29 GB, 460GB, 7420MB)
  6. Type sel dis ? where ? is the disk which is NOT a USB and NOT a disk you are using to setup
  7. Type clean (this will remove all partition formatting and thus it practically wipes the drive!)
  8. Type offline
  9. Repeat for every disk which is NOT a USB and NOT a disk you are using to setup
  10. Type sel dis ?? where ?? is the disk you're using to setup
  11. Type lis par. For me, it outputted, that I have 2 partitions (500MB, 100MB)
  12. Type sel par n where n is initially 0 but it increases each time you repeat it
  13. Type del par. If it outputs any error, ignore it
  14. Type sel dis ?? where ?? is the disk you're using to setup
  15. Type format without any fs or quick - just format
  16. Type exit
  17. Continue the setup. When you're suggested about disks, it should have only Unallocated Spaces (formatted) and each disk (except for your main disk) should be offline.
  18. Select your main disk (that online one) and continue the setup.
  • I have a traditional HDD and a NVMe drive. Setting the HDD to offline made the install go through. Thanks!
    – Frederik
    Jul 9, 2021 at 22:27
  • TLDR: If you don't want to write all this out, remove every single physical device (including secondary hard drives, graphics cards) except the keyboard and mouse. The only disk connected should be the one you are installing windows on. Then it should work.
    – Munib
    Oct 23, 2021 at 1:43
  • 3
    Type clean - unless I'm misunderstanding, this wipes the partition table of the disk. Not a command I'd casually advise someone to do without a big fat warning.
    – davmac
    Mar 14, 2022 at 13:39
  • 1
    unfortunately this series of command stopped working for me when i ran format, with error There is no volume selected. Please select a volume and try again. Here is what worked for me
    – sud007
    Aug 21, 2022 at 18:05

I was getting this with all versions of Windows (Windows 10, Windows Server 2019, Windows Server 2020H2) on a PowerEdge R720. I was just trying to install to a single HDD in the SAS backplane.

Solution was to remove all the other drives (which were not formatted since being members of a PERC RAID array).

This became an issue after flashing the PERC H710P Mini to IT mode (which would have destroyed the RAID array as far as the PERC RAID card was concerned).

I'm not sure why Windows couldn't just ignore these other drives, but presumably formatting them to remove the RAID partitioning would have resolved this issue as well.

  • Wow... my 2nd day of attempts, and your 0-votes answer solved it! Take my vote! My machine had 2 x NVMe, and 4 x SSD. I had to remove the SSDs before the install would work. I used Ventoy, btw.
    – Bram
    Feb 2, 2022 at 17:57
  • Exactly same as me. Thank you for sharing
    – Duloren
    Mar 19, 2022 at 14:05

I have an HDD and SD together on my pc. I simply removed the HDD from its slot and kept it on the table. Then formatted the SSD first. Then I return the HDD back into its slot.


I tried 1000 things, and I had removed my discs and now it works I've 3 HDD and 2 SSD (1ssd for windows) If u have a lot of discs, remove then and maybe it works

  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Jan 5, 2023 at 5:44

Try disabling hdd port from bios after that it will succeed ...i have the same issue...


When you get to selecting the drive for installation do this: Select the drive you want to install windows 2. Delete it 3. New volume and apply 4. Select it and Install windows That’s it. Simply really. Hope it works

  • You don't delete drives. You delete partitions. Also, this question has already been answered, with a rather extensive and clear answer. Your solution would work for certain issues earlier in the installation process, but is not likely to resolve issues at the end where this question is addressed. Mar 29, 2021 at 1:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .