0

Info:

I did a full screen replacement on a X1 Carbon 2nd Gen Type 20A8 Laptop (ThinkPad)

The LCD screen was bad (and I've tried to just change the LCD screen itself), and on my laptop I could not separate the LCD screen from the cover (my unit DOES NOT have the bezel as mentioned in lots of these helpful tutorials). Thus, I purchased a full screen replacement from eBay.

My Problem:

Only, doing the swap... my Laptop is a BRICK and does not turn on at all...

I tried the following:

  1. Replace back the OLD full screen (cover) and it does NOT turn on...
  2. Connect to a working Lenovo Adapter for power... does not turn on...
  3. Holding down the power button for more then 20 seconds (I've seen someplace that that would drain the battery and might help...

I have a feeling there's either some hidden reset button that I'm not finding... Or that when I re-assembled the laptop I missed something.

What else can I try?

Note: I did not disconnect the battery while I did the replacement. Could that have been a cause? And if yes, how can I fix it?

4
  • I would take it to a repair shop for a full test and diagnosis. – DavidPostill Jul 3 '20 at 20:36
  • Thanks @DavidPostill, however, as a DIY type... I'd hope to get something specific of what I can do – lzc Jul 5 '20 at 20:19
  • 1
    It is exceedingly difficult, approaching impossible, to make reasonable suggestions regarding hardware repair without physically observing the device. It is particularly true in this case because, while you list some things you have done, you performed physical work on the device that included disassembling a significant portion of the device and disconnecting and reconnecting important portions of it. The only authoritative thing we can suggest in our position is to take the entire system apart again, and carefully reassemble it with 100% accuracy. – music2myear Jul 6 '20 at 18:14
  • For the record, I posted my "answer" before I've heard from @music2myear's advice :) Obviously, that was the correct thing to do... – lzc Jul 6 '20 at 20:36
0

After some further DIY wranglings, and numerous show-n-tell clips, particularly this one, I decided to disassemble/reassemble and NOW IT WORKS

Only, I'm not sure exactly what did the trick, I can think any of the following:

  • Disconnected the battery as first step
  • Was extra extra careful not to nick any wires
  • Pressed that little reset button (while cover was OFF [BTW: on my laptop a paper clip is too thick to access the reset btn!])

Interestingly, not sure why, there was a BIOS error msg something about a problem with system clock! So I went in, and set the time... and then Windows restart PERFECTLY (in fact, I've gone off with hibernate! When it came back, all my work/windows etc... were all up-n-running)

There's one problem though, "Touch" screen is not working! The guy on eBay sold that it has Touch. (Hmm, maybe a reboot would help, I wonder?)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.