Having a constant issue with (what I assume to be) permissions on Windows 7.

I have a certain number of files I need complete access to (actually, Visual Studio needs unrestricted access to - to build my solution)

As you can see in the below screenshot they are 'blocked' because they've been downloaded from the internet.


My issue is that whenever I click Unblock, Apply & OK, it restricts the file automatically again as soon after. ie I unblock X file, reopen the properties and it needs unblocking again.

Is there a perma-unblock or am I missing something?

I'm aware I can turn the "block downloaded files" feature off in gpedit, but this has not solved my issue


I think is is a weirdo issue dealing with UAC and program files. Try turing off UAC; go unblock the file; and then turn back on UAC. I think the problem occurs because the properties window doesn't automatically elevate when doing unblocking.

Alternatively, move the file out of program files to somewhere ordinary like your desktop. Unblock it there, and then move it back.

Try the second way first, since it doesn't involve turning UAC off.

  • Second way worked a charm. Crazy stuff. Cheers. – Daniel May Jun 25 '10 at 11:02
  • I had this exact problem and did what Knox suggested with no result. I solved the problem by creating a .zip file from the blocked file and then extracting it. – Ale Apr 6 at 22:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.