The vlc player is such a great tool, however it is not working properly on my Ubuntu 20.4 Laptop. Specs: AMD® Ryzen 7 pro 3700u w/ radeon vega mobile gfx × 8 The issue: When I start the player, it is playing properly. But as soon as I close it, the icon stays at the top right corner, and there is no way to play videos with this instance.

I can still open new instances with the vlc player, but then further icons are occurring.

enter image description here

A screen record can be seen here: https://www.reddit.com/r/VLC/comments/hi4guw/ubuntu_2004_vlc_does_not_reopen_once_its_closed/

Any ideas? My current solution is to I kill the process in the terminal

  • pkill may come in handy ... but on my system I am able to click these icons on the panel and quit the instances individually. But I agree that it's annoying. Question: are you using the snap or the Debian package (dpkg -l|grep vlc vs. snap list|grep vlc)? Jul 7, 2020 at 9:47
  • Thanks for answering, I installed it from the ubuntu software store, so I guess it is snap. Writing the two commands that you posted both give me outputs in the terminal
    – Kolibril
    Jul 7, 2020 at 12:47
  • I have the same problem with VLC, but another additional part, how is your laptop power consumption? For me with AMD ryzen, its very high. Oct 27, 2020 at 1:55
  • Related bug posted on VLC forum Feb 8, 2021 at 10:48
  • Related: askubuntu.com/questions/1250477/…
    – caw
    May 28, 2021 at 18:54

7 Answers 7


Go to Tools > Preferences, then Inputs/Codec tab.

Change Hardware Accelerated decoding to something other than Automatic or VDPAU.

Source: https://bugs.launchpad.net/ubuntu/+source/vlc/+bug/1871949/comments/8

  • 2
    Solved my issue. Oct 27, 2020 at 1:57
  • 3
    worked for me by changing Hardware Accelerated Decoding to "Disable". No performance issues.
    – brett
    Dec 13, 2020 at 18:31
  • 1
    didn't work for me
    – Charon ME
    Dec 30, 2020 at 17:23
  • it solves earlier, but i update kernel and vlc. I can't find those option anymore Apr 10, 2021 at 3:19
  • 1
    @AdiPrasetyo: I'm on updated 20.04 with kernel 5.10.18 and I still can see this option. Apr 10, 2021 at 14:37

I’ve had a similar issue with the VLC media player. I found that the closed player will only stay around and remain unusable when I close it with the window close button (usually a red circle in the top right corner with an “X”). If I instead close the player with Ctrl+Q, Alt+F4 or via “Media” → “Quit”, then the player is closed properly.


I eventually logged a bug report with VLC and the response was very good and it turned out to be how I closed VLC that was the problem. I always clicked on the "X" in the top right hand corner to close VLC. When I repeated this action the VLC icon on the status bar would not disappear and VLC was unresponsive. I had to reboot Ubuntu to get rid of the icon on the status bar.

THE SOLUTION: Close the current song / video by clicking on the "Stop playback" at the bottom left then use the "X" at the top right or click on "Media" at the top left and click on "Quit".

I tested the "solution" by repeating it several times and it worked perfectly every time.


I also had this problem (Linux Mint Cinnamon 20.1), but i could fix it with:
disable Tools > Preferences > Interface > Playlist an Instances > Use only one instance when started from file manager

aside from that, there is also:
enable Tools > Preferences > Interface > Playlist an Instances > Allow only one instance
disable Tools > Preferences > Interface > Look and feel > Show systray icon


Somehow vlc is exit properly when I do quit with ctrl + q. My answer is maybe just relevant to vlc that installed via snap.

The external attempt to kill all vlc instance is using:

killall -9 $(pgrep vlc)

The proper permanent solution is present at https://learnubuntumate.weebly.com/vlc-closes-fix.html

Which I found from forkirara's answer at https://askubuntu.com/questions/1250477/vlc-is-still-running-even-i-closed-it-already-how-to-i-close-it

The copy-pasted answer is :

  1. Delete folder /home/your user/.config/vlc
  2. Open vlc
  3. Open Preferences dialog, click on the Videos tab or button at the top. Then change our output to OpenGL video output.
  4. Then click on the Input / Codecs tab or button at the top. Then change Hardware-accelerated decoding to Disable and then click the Save button. Now close VLC Media Player.

Works for me as well !


I just disabled the systray icon in Tools->Preferences->Interface tab.

  • 2
    and that process still running! Mar 19, 2021 at 15:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .