4

Windows 10 was supposed to end the need to safely eject drives, so why does it (a) still include the eject icon in my tray? (b) say "This device is currently in use. Close any programs or windows that might be using the device, and then try again."?

And why does it not say which programs are using the device? Almost every time there is no program using the device, as far as I can tell. Shouldn't Windows be able to tell me which programs are using the device, and ask me if I want to close those programs?

On others' posts I've read "just pull it out anyway", and I've read "you'll be sorry". At this point, I'm not particularly looking for opinions of what to do. I want to know what I asked.

Thanks

3
  • Its always better to use the safely eject, sometimes you can log off and back on then it will safely eject without errors. – Moab Jul 9 '20 at 18:24
  • Safely ejecting a USB drive unmounts the filesystem before it's removed from the device and is recommended to prevent filesystem corruption, which will eventually happen if safely ejecting it is not used. I'm unsure where it's stated this would no longer be necessary on Windows 10, as Windows doesn't "know" when a user is going to disconnect a USB storage device before doing so - that's the purpose of safely ejecting the drive. – JW0914 May 11 at 11:45
  • “Windows 10 was supposed to end the need to safely eject drives” – citation needed. Simply said, this cannot be achieved, ever. – Daniel B May 11 at 13:03
4

In the early days of USB, things were pretty flaky and you were likely to blue-screen your computer if you unplugged a USB connection without due care.

USB is now far more robust and reliable and you are unlikely to have those types of problem. However, there is also the quite separate question of caching.

When writing data to a USB device, caching is likely to be used to boost overall performance. This means that you may think your file copying has completed, but part of the file is still in memory and is still being written to the USB device. For this reason, the safe removal function is still very necessary. If you unplug a USB device while it is being written to, you are very likely to corrupt your file and possibly also damage the USB device.

The safe removal function ensures that the data transfer to the USB device completes and the file is closed, so that you know when you can remove the USB device without corrupting your data or damaging your devices.

(If you want to find out what process is accessing the USB device, you may use the Sysinternals handle utility.)

1

The main program that it will not tell you about is Windows Explorer and anything that uses the Windows Explorer Sub Subsytem. Also any Explorer third party (Tree Size, xPlorer2). Make sure these are all closed, also close any App Save (As) window.

The apps / systems above hold the USB in Use until cleared.

I normally close Explore windows (Open / Save) in Apps (Office, Adobe, Other) quickly so as to minimize this interference. Then I usually just have to close my main File Explorer instances.

When all the above are closed, wait 15 seconds and eject again. This normally (90%) works for me.

Windows 10 did not end this need, and I am not aware that it was supposed to end the need. I have been using Windows 10 for 5 years now.

2
  • A cmd shell with the drive set as the current working directory will also cause this. There are just too many potential programs to list ... – DavidPostill Jul 9 '20 at 21:07
  • I normally use Open/Save windows in apps like Office and Adobe quickly and close these quickly. This minimizes open explorer instances. – John Jul 9 '20 at 21:13
1

If closing all programs that could be accessing the drive doesn't work, try emptying the recycle bin for that drive or a quick format (after first saving any needed files in another location).

I had a 200G USB drive that I used regularly for transferring files. When I deleted a tree, I had always used Shift-Delete for immediate delete / bypass recycle bin. Eject worked with no delay. But several times I accidentally used Delete and many files went into the recycle bin. Then every time thereafter when I tried to eject, I got the "This device is currently in use" message.

The SysInternals Handles utility showed several handles related to the recycle bin. After a quick format, ejection requests immediately succeed every time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.