1

This could also be related to a recent windows update. I recently updated to 2004 to be able to run WSL2. When I virtualized the machine I followed the recommended Oracle Virtual box steps, which included running a script to remove the disk adapter drivers. then I imaged the disk over to a VMDK. Everything on the machine runs fine, there are the occasional bugs, that don't seem related to this.

When I RDP in I get the error message below.

I have found several error messages in the Event Viewer on the Remote Machine. All of the interesting ones seem to be under RemoteDesktopServices-RdpCoreTS. Here are some of the more interesting ones in order.

  1. 'Failed GetConnectionProperty' in CUMRDPConnection::QueryProperty at 3344 err=[0x80004001]
  2. 'Connection doesn't support logon error redirector' in CUMRDPConnection::GetLogonErrorRedirector at 4657 err=[0x80004001]
  3. 'Failed GetConnectionProperty' in CUMRDPConnection::QueryProperty at 3344 err=[0x80004001]
  4. Disconnect trace:CUMRDPConnection Disconnect trace:'calling spGfxPlugin->PreDisconnect()' in CUMRDPConnection::PreDisconnect at 5073 err=[0x12], Error code:0x12
  5. TCP socket WRITE operation failed, error 64
  6. TCP socket READ operation failed, error 64

Here are some of the things I have attempted so far.

  • Confirmed IP Address
  • Disabled Firewall Attempted to disable RemoteFX via GPO https://serverfault.com/q/886027/95189 then
  • attempted to disable it via Registry. Added and then removed
    • Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\fEnableRemoteFXAdvancedRemoteApp with 0x00000000
  • Attempted to increase the Max Outstanding Connections
  • Changed RDP host hostname
    • Some research indicated something about cloning machines could confuse the network.
  • Install VirtualBox Extension Pack
    • Running 6.1.6 on everything
    • 6.1.10 seems to be the latest via Oracle, but with the Ubuntu repos 6.1.6 seems to be what they have available.
  • Disabled Nested VT-x/AMD-V
    • Something about RemoteFX requiring this feature, so I attempted to disable RemoteFX by removing its requirement.
  • Disable URCP
  • Attempt to update Hyper-V Virtual Machine Bus Provider but it failed.

Screenshot of error message when using RDP to connect to remote windows machine

4
  • Were you ever able to get this fixed? Oct 29, 2020 at 21:06
  • No I was not able to.
    – TMB
    Oct 30, 2020 at 22:58
  • That's too bad. My issue sounds similar... superuser.com/q/1598296/28834 Nov 1, 2020 at 1:06
  • I took a look at your first few lines... my issue isn't freezing, but rather wont connect at all. Some of those error messages are similar though. I might work on it again soon. Thanks for reminding me, I'll ping your question if I make any headway.
    – TMB
    Nov 5, 2020 at 0:09

2 Answers 2

1

Solved for me:

The last thing I tried in VMware was a checkbox for that specific machine. "Accelerate 3D graphics" <- Uncheck this box.

This was a real computer that I virtualized. Windows 10 (Guest) Running on WMware Workstation 14 Pro. The host computer is running windows 7

I have been down the path of everything you have already tried. Wish I could restore every little change and just hit that box. Lost a day of work too.

2
  • Ok, that sounds like something I would do. Not sure if I still have that VM around, even if, I am moved on to qemu.
    – TMB
    Dec 16, 2021 at 22:50
  • Oh wait I was using virtual box. Even still I am pretty sure I would have clicked the accelerate 3d graphics.
    – TMB
    Dec 16, 2021 at 22:52
0

We noticed we had installed a VPN client on our Windows Server 2016 (Netmotion) which was also having a problem loading. Uninstalled netmotion and problem solved.

but I had also applied the registry entry you mentioned above.

so which one fixed it? don't know, but we can now RDP into our server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.