2

I have an Intel E7300 Core2 Duo processor with 2.66GHz speed. I need to run a 64-bit WinXP SP2 VMWare image. My host operating system is Win 7. So I just installed the VMPlayer from www.vmware.com.

The problem is when I run the VM image it says This host doesn't support VT. If I continue I see Windows shows an error message saying

Attempting to load an x64 operating system, however this CPU is not compatible with x64 mode.

My question is how do I run this VM without buying a new processor? Any other tools or software?

  • 1
    Wild ass guess here... VM needs Intel VT support to run a 64bit OS. Your motherboard's chipset does not support Intel VT. So either run a 32bit OS, or get new hardware. Or use a different virtual machine manager. But I might just be flat out wrong. – user939 Jun 25 '10 at 19:02
  • @Will It’s the CPU, not the chipset. – kinokijuf Jan 24 '12 at 15:33
  • 2
    @kinokijuf It must be supported First by CPU. Then by Chip set. Otherwise OS can not utilize it. – Shiplu Mokaddim Jan 24 '12 at 16:55
7

Intel Core 2 Duo E7300 doesn't have Virtualization Technology (VT) support. Intel's website has a whole list of which processors support VT-x here.

enter image description here

So you cannot run 64-bit operating systems in a virtual environment. You will have to use a different processor which supports VT-x (or AMD-V in case of AMD processors).

| improve this answer | |
  • Seems I have to buy the "YES" marked ones!! – Shiplu Mokaddim Jun 25 '10 at 23:50
5

Apparently VMware and VirtualBox don't support 64-bit guests without VT (at least, as of Aug 2009)

Since your CPU does not support VT (as Om Nom Nom pointed out), you'll have to either upgrade your CPU or switch to a virtualization product that does support 64-bit VMs without VT (Xen was suggested in the Serverfault question, but I don't think you can install Xen on a Windows host).

| improve this answer | |
  • I'll go with Xen. Is it possible to install in Ubuntu? In fact I dont want to download another 32bit sister of this 24GB vmware image. It takes a lot of time to download. – Shiplu Mokaddim Jun 25 '10 at 23:54
  • 1
    Yep, you can install Xen on Ubuntu. Here are some instructions, although I'm not sure if they're for the very latest version: help.ubuntu.com/community/Xen – rob Jun 26 '10 at 0:40
2

Have you checked your BIOS to make sure that VT is enabled? Some machines (including mine) ship with it disabled. I just had to enable it in the BIOS and it was good to go...

| improve this answer | |
0

All 64-bit virtual machines require VT-x to virtualize x86_64, because isolation of the virtual machine would be impossible without it1.

So unless you buy a VT-x enabled CPU, you have only one solution, that is using an emulator such as Bochs or QEMU. But since everything is emulated, the speed is slow (or very slow) and may only suitable for not very heavy operations.

It's easier for Linux and other OSes with open-sourced kernel since you can use paravirtualization like Xen which may be even better in terms of performance compared to hardware-assisted solutions because of the low overhead. It modifies the kernel to work so unfortunately it's not available for Windows

Another alternative is to install a 64-bit OS and then run 32-bit guests inside it

Not sure if it's too late or not but hope it'll help you and any one with a CPU without VT-x.

Related:


1 https://en.wikipedia.org/wiki/X86_virtualization#Software-based_virtualization

The initial version of x86-64 (AMD64) did not allow for a software-only full virtualization due to the lack of segmentation support in long mode, which made the protection of the hypervisor's memory impossible, in particular, the protection of the trap handler that runs in the guest kernel address space.

Revision D and later 64-bit AMD processors (as a rule of thumb, those manufactured in 90 nm or less) added basic support for segmentation in long mode, making it possible to run 64-bit guests in 64-bit hosts via binary translation. Intel did not add segmentation support to its x86-64 implementation (Intel 64), making 64-bit software-only virtualization impossible on Intel CPUs, but Intel VT-x support makes 64-bit hardware assisted virtualization possible on the Intel platform

| improve this answer | |
-1

You have to go into your Bios and (under the Security tab for some machines) and update your Virtualization (set to enabled). On Intel CPUs it's called Intel VT. Once you do this you will be able to virtualize a 64bit core.

| improve this answer | |
  • The accepted question already stated that E7300 doesn't have Virtualization Technology (VT) support – phuclv Apr 6 '14 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.