I am trying to update my Lenovo T460 bios to latest version:

Version (https://pcsupport.lenovo.com/fr/en/products/laptops-and-netbooks/thinkpad-t-series-laptops/thinkpad-t460/downloads/driver-list/component?name=BIOS%2FUEFI).

Normally it is not a problem to update the BIOS but my battery is dead (and can't order a new one due to COVID-19 in my location) and the update tool says I need the battery to be charged.

Do you know of any switches like Dell BIOS typically has, i.e.


5 Answers 5


Lenovo requires a working battery, decent charge (at least half) and plugged into AC. This is to prevent possibly bricking the BIOS chip. There is not a facility within the Lenovo BIOS update application (and looking through the documentation) to update with no battery.

I have done lots of Lenovo (and IBM) BIOS updates for myself and for clients.

I have ordered parts during COVID. Try Lenovo Sales Support and also 3rd party suppliers with warranty approved parts.

  • Hi John - thanks for the reply. I know that the risk of bricking the machine but that is not my question. I am in a remote place in Africa and here it is not possible to order for the next foreseeable future unfortunately.
    – Sha
    Jul 17, 2020 at 10:38
  • I edited my answer to amplify the point that no switch is available to update without a battery.
    – John
    Jul 17, 2020 at 10:56
  • This is the official Lenovo answer BUT it is possible.Though Lenovo try to avoid flashin without complying with their rules, it is possible to flash BIOS/ECP without battery check. See my answer below Nov 12, 2020 at 9:05

After a month searching the internet, I finally got my Yoga X1 Gen2 bios updated without battery. It was much more simple than I thought.

  • download the official bios on lenovo support page and extract it.
  • Run WINUPTP64.EXE or WINUPTP.EXE using command line with "-sp" option.

In my case, in CMD, I typed: C:\DRIVERS\FLASH\n1nuj30w\20210302.08305818/WINUPTP64.EXE -sp

Command line options:

   "  -s        ... Silent mode\n"
   "  -r        ... Reboot after program completed\n"
   "  -sp       ... Skip power status check\n"
   "  -chk      ... Check current TPM firmware\n"
   "  -suc password ... Skip user confirmation at startup\n\n"
   " Note: -suc option requires supervisor password.\n"

source: https://thinkdeploy.blogspot.com/2017/11/tpm-firmware-update-utility.html

  • 1
    Does not work, because the -sp option is for TpmUpdt64.exe, not for WINUPTP.exe. Dec 12, 2021 at 21:15
  • 1
    -sp worked like a charm for me with WINUPTP64.EXE.
    – leifericf
    Feb 2, 2022 at 16:23
  • I needed to change into the directory by executing cd C:\DRIVERS\FLASH\n1nuj30w\20210302.08305818/ and then executing WINUPTP64.EXE -sp from there
    – fupduck
    Jun 23 at 9:47

Following info and steps worked in my old lenovo

The bios zip file includes:

  • 2 files .FL1(BIOS) and .FL2 (ECP: Embedded Controller Program / platform)
  • executables with a name similar to winphlash (can be DOS or windows)

winphlash can backup current BIOS and apply a BIOS with extension .ROM and will not check for battery.

The .FL files have the format required by winphlash, so you can rename the extension FL1 to ROM or just force the filter to pick the FL file

I managed to Flash the FL1(BIOS) and it is recognized and works.

However I didn't know what to do with FL2 file, I tried to flash as i did with BIOS but I received a warning message saying that version and code is not the expected.

(update: ECP should always be flashed before than BIOS)

Anyway, despite the message I flashed the ECP/platform ROM and everything worked well.

BTW I don't consider buying a new battery the best solution. Because in the practise not all people need a battery and for old laptops the cost can be similar to the laptop price.

  • Thanks for answer. Can you elaborate on which Lenovo model you have, and also what bios file you used?
    – Sha
    Dec 29, 2020 at 15:06
  • 1
    @Sha i applied on a X61 but the procedure should be similar for other lenovo laptops. Unfortunately I have not a modern lenovo to verify. there is good BIOS Upgrade info in thinkwiki.org/wiki/BIOS_Upgrade Jan 4, 2021 at 11:26

On Lenovo ThinkPad X230i was enough to copy BIOS (*.FL1) and ECP (*.FL2) files to parent folder, where WinFlash64.exe is located then run cmd.exe as administrator and enter command:

> cd <path/to/WinFlash64.exe>
> WinFlash64.exe /file $01D3000.FL1

where $01D3000.FL1 was my BIOS file. ECP had the same name but "the next" extension like $01D3000.FL2 and it was probably taken automatically based on numeric pattern.


Since this is the only related thread: For the Lenovo Ideapad 120S-14IAP I had to go to the BIOS folder and edit the default.rsp file by changing the line /cbp 20 to /cbp 0.

I assume that cbp stands for something like charge battery percentage, and that the default minimum level is 20%.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .