1

I bought the Dell S2417DG which includes GSYNC, and I am getting some horrible artifacts (maybe more often with darker colors). It appears to occur in any resolution. My other Acer monitors on the same PC do not have this issue. The monitor is plugged into my RTX 2070 with a DisplayPort cable. Seems to happen anywhere: Netflix HBO Max, JPEGs, etc. Taken with a camera:

How can I fix this?

NVIDIA settings for the monitor: enter image description here

More comparisons in high-res:

This is the same PC hooked up at the same time.

Things I have tried that did not help:

  • Trying a different cable
  • Trying a different port on the GPU
  • Resetting the monitor to factor settings
9
  • It looks like you are playing a movie. Is that the only time this happens?
    – Keltari
    Jul 20 '20 at 0:57
  • @Keltari No, I see artifacts on still pictures too.
    – Zeno
    Jul 20 '20 at 0:59
  • I doubt its the monitor. More than likely its a configuration/setting of the video card and the monitor. However, it wouldnt hurt to test the monitor on another graphics card.
    – Keltari
    Jul 20 '20 at 1:51
  • Do you have the latest nvidia drivers? Did you try updating the drivers for the monitor as well?
    – GChuf
    Jul 24 '20 at 12:46
  • @hextech I have upgraded my GPU drivers and monitor drivers, same issue remains.
    – Zeno
    Jul 25 '20 at 0:10
0

To me it looks like your graphics card or your monitor applies some gamma correction to the display output, heavily brightening the dark parts in the process, which makes compression artifacts and color banding much more visible. Some monitors have a feature, often called "Black Equalizer", which does something similar. I would reset your monitor settings first, if the issue is still there I would look in the Nvidia Control Panel for something that could cause this, and then also check the individual monitor settings.

5
  • There is no such setting on the monitor, or anything similar. What I am looking for on Nvidia Control Panel?
    – Zeno
    Jul 25 '20 at 0:02
  • @Zeno I don't own an Nvidia desktop GPU myself, but you should be able to find the setting under Display -> Adjust Desktop Color Settings. But if you haven't messed with those settings before they should still be on default, where they normally should be. There's also a feature in Nvidia Freestyle, called "HDR Toning", which could also produce such artifacts by brightening dark parts on the display. It might be helpful to do look at some test images from here, especially "Gradients" and "Gamma", to understand what's going on.
    – damian101
    Jul 26 '20 at 9:36
  • Also, have you tested if those artifacts get baked into screenshots?
    – damian101
    Jul 26 '20 at 9:36
  • Everything looks fine under Adjust desktop color settings. The settings are literally the same for all 3 monitors.
    – Zeno
    Jul 26 '20 at 14:29
  • I uploaded an image of the NVIDIA Control Panel settings to the question.
    – Zeno
    Jul 26 '20 at 21:09
0

It looks to me like the 'artefacts' are present on both screens in the same place...just that the new monitor colour / brightness / contrast levels are emphasising it. Have you tried something really high definition like a blu ray or 2k youtube video to see if it still shows? Could be an overheating graphics card if it's completely random?

Perhaps check that all your cables are up to the latest spec? HDMI cables are not all alike. Maybe swap to display-port if available?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.