0

System:

  • Ubuntu Mate
  • Ubuntu 20.04
  • with Linux 5.4.0-42-generic

I have also tried changing the Kernel version to Linux 5.4.0.40-generic, but the symptoms persist.

After rebooting my laptop, I attempted a login as usual. This time, however, I get a black screen and no use of keyboard or mouse that I can tell. Once this has happened, I can't do anything but hold the power button. Ctrl+Alt+F1 does nothing in this state.

If instead of logging in with the GUI, I press Ctrl+Alt+F1 from the login screen, tty1 comes up and I can log in perfectly fine from there with no issue.

From there, I tried startx with nothing happening, except an IO error, which may be the cause. If I do sudo startx the GUI boots mostly fine, with some strange glitches here and there.

I have not recently installed any strange packages that I'm aware of, but I did hold the power button during the shutdown cycle, since it was taking longer than normal. I did this right before things went wrong, so it could be that as well.

One other thing to note is that I'm getting messages about having 1GB of space left, while the Disk Usage Analyzer says I have 13GB. Which one is wrong and what the implications are to this issue, I'm not sure.

Any insight is appreciated!

  • Can you mention the ubuntu version you are using . Some times it will be a kernel version error . As a solution I suggest that switch to the additional options in the boot screen , select and switch to a previous Ubuntu kernel version. – kaviranga Jul 21 at 6:48
  • 1
    @kaviranga, I just edited the post per your suggestions. The issue persisted with the Kernel change as well – nathaniel.graham Jul 21 at 15:53
  • 1
    Woo! I got it! I'll post the answer and mark it – nathaniel.graham Jul 21 at 15:58
0

While I'm not sure what the exact cause was, I can explain how I fixed it.

I booted into recovery mode for Ubuntu, with Linux 5.4.0.42-generic and ran dpkg repair packages. Doing this, two packages were removed, which I expect weren't the issue (one was zoom and the other was ibus). 6 packages were added, however, including llvm-10-dev among other similar things. After returning and continuing to boot, I logged in just fine with no issue.

If anyone has insight as to why this contributed to the solution, I'll happily add it here to help myself and any future readers understand why this caused the problems it did (or maybe users with more points can even edit it themselves like they can for questions?)

Thanks to those who gave me advice!

| improve this answer | |
  • Something that might be important here is that when it all started working again, my /etc/X11/xorg.conf.d folder had been deleted. – nathaniel.graham Jul 21 at 16:22
  • Now you can accept your answer and increase your reputation to this community . You can earn a batch too ! – kaviranga Jul 21 at 17:52
  • 1
    Awesome! Looks like I have to wait until tomorrow, but I'll be doing that right away :) – nathaniel.graham Jul 21 at 17:57
  • Best I can tell, it seems like two different things happened at once, which resulted in what looked like one symptom. 1. My dependency tree was broken, which caused some xserver configurations to get removed 2. It also removed my keyboard and mouse drivers (ibus). These caused the screen to go dark at the same time the keyboard was turned off, preventing me from turning the brightness on, and therefore the screen on. The solution for me to fix the brightness bit was to add the rc.local file, which had been removed. – nathaniel.graham Aug 4 at 0:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.