0

I'm not 100% sure if Super User is the right site to ask this question so I'm apologizing in advance if it's not.

I need to be able to attach external HDD to this Kali Linux virtual machine. I followed a tutorial on the web but even after following it step-by-step it's still not detecting the HDD attached.

Please see below:

Installed virtualbox guest extensions pack

enter image description here

Enabled USB 2.0 in settings

enter image description here

Ran sudo usermod -aG vboxusers mark

enter image description here

then logged out and logged back in.

After launching the virtual machine it's still not detecting the HDD.

enter image description here

When I hover over the USB icon it says No device attached. It's VirtualBox 6.1

Can anyone please tell me what's missing ?

unmounting the HDD from host machine and running sudo fdisk -I reveals:

enter image description here

The disk's capacity is 750GB so it's safe to say that Kali isn't detecting it for mounting.

Kali on VMWARE:

enter image description here

enter image description here

I tried this while the pen drive was mounted and when it wasn't mounted.

1
  • How did you add the filter? Manually or using the menu while the VM was running? It may simply be wrong. You need to check the actual VM state to see which devices are attached.
    – Daniel B
    Jul 27 '20 at 15:46
0

Connect the USB drive to your machine following this tutorial below. I tried this on my own Kali machine and could see the USB key just fine.

sudo fdisk -l <-- to see the USB key physically. (say sdb1)

sudo mkdir /media/usb-drive <-- to make a mount point.

mount /dev/sdb1 /media/usb-drive/ <-- to mount the drive.

https://linuxconfig.org/howto-mount-usb-drive-in-linux

See the two connection screenshots below: one for connecting the drive and one to see the related FDISK output. Also see the dialogue allowing the USB Key Pass through to be connected to the Guest.

You need to ensure the drive is seen before you can mount it and see the contents. You might see slightly different dialogues in Virtual Box.

enter image description here

enter image description here

enter image description here

14
  • There's a limit for how big the hardisk can be on virtual machine ? OK I'm gonna try a pen drive.
    – Mark
    Jul 27 '20 at 16:45
  • No, no difference. Pen drive with 8GB isn't detected either.
    – Mark
    Jul 27 '20 at 16:47
  • Did you connect the flash drive to the Guest via the Virtual Box Menu for this operation? You may wish to try a trial version of VMware. This is definitely working here.
    – John
    Jul 27 '20 at 16:48
  • I just try to add a One TB USB drive and no go. So size is a limit.
    – John
    Jul 27 '20 at 16:53
  • 1
    Fair enough. I do not know why your machine isn't working. I have used USB pass through for a number of years and set up Kali to see / read the USB key today. Try another virtual machine to test. Make sure Kali is the full Desktop Version (there is more than one variety of Kali). I use the Full Desktop version.
    – John
    Jul 27 '20 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.