0

I have an enclosure that supports two hard drives in RAID 1 mode. A few days ago I connected the enclosure to my laptop and Windows was giving me errors saying it couldn't read/load the D: partition. I believe it must have been disconnected without "removing it safely", maybe because of a reboot or sleep, I'm not sure.

The fact is that I can't see the files anymore, neither in Windows nor Linux. Nothing is able to load the partition. They're two 4GB HDs NTFS-formatted. I tried using TestDisk, but it started giving me errors after 75% of the analysis (and 5 days later). I can try again, but I really thing it's a simpler situation than usual. I haven't formatted anything by mistake so I believe the files are there, it just seem to be a problem caused by disconnecting the enclosure without "removing it safely".

Does anyone recommend any software or any way to recover it?

Btw, I've tried doing a simple "chkdsk D: /f" with no success. However, chkdsk does recognize the partition as NTFS whereas the Disk utility from Windows recognizes it as RAW.

5
  • 1
    If testdisk is throwing up errors its likely a hardware issue. You may want to use the other half of the array and/or use ddrescue to try and pull the (raw) data off. – davidgo Jul 29 '20 at 9:09
  • Also, have you tried reading (WITHOUT MODIFYING -is read-only mode) one half of the array? – davidgo Jul 29 '20 at 9:11
  • Regarding ddrescue, I need to get another hard drive as big in order to pull the data off. Right now, I just don't have the space. I'm currently running Disk Internals Partition Recovery on the second hard drive. It seems to be finding files, even though I can't see them yet. It's about 38% but it takes forever. Most probably it will only finish by tomorrow. Regarding the errors from TestDisk, it might have been some Windows problems (going to sleep or whatever). I had that before and had to restart. I could run it again. The only problem is that it really takes forever to run. – Jon Santos Jul 29 '20 at 9:21
  • If your drive is failing, anything you do to recover the data is likely compounding the proble.m. Have you checked S.M.A.R.T values on the hdds to see if the drives think they are OK? – davidgo Jul 29 '20 at 9:27
  • According to CrystalDiskInfo, everything is fine ("Good" as the app says). The Disk didn't have any crash, fall, hit, overheating, nothing really. And these are WD Red. – Jon Santos Jul 29 '20 at 9:36
0

Well, I've managed to recover the files using a tool called DMDE Express (the express versions costs $20). The files somehow got into a hidden partition but were all there. Nothing got lost. I plugged only one of the disks directly into my laptop using a SATA-to-USB adapter.

I believe this problem could have been solved with TestDisk. However, it was taking way too long for any type of scan. By long I mean a week just for the analysis.

Anyway, just posting what's worked for me here in case anyone faces a similar problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.