My towerised Amiga 1200 came out of storage recently and I've been messing around with it a bit. I decided to give it an OS upgrade so I purchased Kickstart 3.1 ROMs and Workbench 3.1 disks.

I swapped out the Kickstart ROMs (while using an anti-static wrist strap, of course) taking note of the correct orientation and which ROM part number goes in which socket. Then hit the power....and it doesn't work.

When powering on it's an immediate white screen - no black or dark grey for half a second, it's immediately white. However the power LED did light up dim for half a second then go to full brightness, as normally happens on an Amiga.

I swapped the original Kickstart ROMs back in and they too are giving the same problem. I've disconnected all the peripherals I can to rule them out. I've pushed the ROMs in as far as I can, and although they are not pushed in as far as they were at the start, I'm confident they are making good contact with the sockets.

Any idea what's happened? Have I toasted both ROMs, or the sockets, or something else in my Amiga? What do I try next? Is there any meaning to the white screen - I'd expect a color flash to indicate a fault.

Here's the way I have installed the ROMs:

^^^^^^^rear of Amiga^^^^^^

 |)   P/N 391774    |
 |)   P/N 391773    |

vvvvv front of Amiga vvvv
  • Sounds like a classic example of toasting some component. I know you probably don't have access to a ton of amiga (or is it amigas) but if you could try your ROMs in another amiga you could tell whether it's the rom or something else.
    – Daisetsu
    Dec 10 '10 at 23:57

Here is what happens in the Amiga boot sequence. Since you're not getting to #3, "Clear the screen", I am guessing you broke a trace or a component on the motherboard somewhere in the process.

  • Ouch. I had assumed that something like this had happened but hoped there was another (easier to deal with) answer. Thanks for confirming though :) At some stage I might buy another set of ROMs to try out in case it was just the ROMs I toasted, but I don't have a lot of hope... Dec 28 '10 at 12:25

Well, 5 years later, I have a new answer to my question.

I recently took this Amiga out of the garage, looking to salvage it for spare parts. Out of curiosity I hooked it up to a screen and powered it on. Instead of the white screen I had seen before, it was showing a dark grey screen. Over the following weeks, I tried powering it on again on a few occasions, and always saw the dark grey screen.

Then one time - to my amazement - it successfully powered up and showed the "insert disk" animation (and correctly identified the 3.1 ROMs).

It has worked ever since - I've reconnected all the peripherals to it, installed a flash drive, and had no problem at all installing and using Workbench and other software.

Therefore the answer to this problem is "leave it in a garage for five years". But I suspect that may not be a reliable answer.

A more practical answer might be "get it re-capped" (i.e. have all the capacitors replaced) as apparently it is common for the cheap capacitors Commodore used to degrade to the point where the computer no longer powers on. This may well have been the cause of this problem, although why they would then start working again, I do not know, but I will be doing this as well to try and guarantee continued reliability!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.