0

I'm trying to access a webpage that's hosted locally on my main PC from another device (for mobile web development purposes).

The webpage is hosted by Brackets' Live Preview functionality, on 127.0.0.1:59605. I tried opening up that port in Windows firewall, I tried completely disabling Windows firewall, and I've checked all routers / APs to make sure that all firewalls are turned off there as well. Still, [mainPcIP]:59605 returns "this site can't be reached" after a long loading time.

Figuring that I was trying to do something that simply doesn't work, I tried an app called BrowserSync. Here I tried serving the html files directly through it's "server mode", and I tried proxying the Brackets IP through it. Both options give me a local IP different from my main PC's IP, with port 3000. I tried that directly, then again tried opening up that port in Windows firewall, and again completely disabling Windows firewall, still no luck.

I've also got Pi-Hole running on my network, which I've disabled for all this testing, this also didn't have an effect. As far as I know, Pi-Hole doesn't offer any firewall-esque services anyway, but I thought I'd still mention it.

I've tried accessing all aforementioned from two different machines, with the same result.

Then I tried using a Chrome app called "Web server for Chrome", which creates a web server on localhost:8887, hosted a simple folder structure on my secondary PC, disabled the firewall there, and tried accessing the [secondaryPcIP]:8887 address on my main PC. This worked just fine. I tried doing it in reverse (hosting on the main PC, accessing on the secondary PC), and this didn't work.

Basically, I've come to the end of my capabilities. What could be preventing me from accessing these webpages?

0

1 Answer 1

1

With the details you've given it seems like Brackets' Live Preview only binds the port on the loopback device.

Open a command prompt and enter:

netstat -na |findstr "LISTENING"

What you may find is that the port you think is open across your real network is not listed as "0.0.0.0:59605", meaning it is not bound on all network interfaces. Instead you may find it is only listed as "127.0.0.1:59605", meaning it is only listening on the localhost/loopback device, not any real network devices.

Many tools that allow a localhost/loopback preview in a browser on the same machine intentionally do not bind their test port on any physical/real network interfaces. There may be an option in the software to change that, or there may not be.

With that generic answer out of the way... This may answer your question for the specific tool you mentioned: https://github.com/adobe/brackets/issues/6424

See: https://docs.microsoft.com/en-us/windows-server/administration/windows-commands/netstat

3
  • Thank you for your answer. You're right about port 59605 only being available to localhost. However, that's why I also tried the proxy and the Chrome web server. While this explains why I can't (directly) access port 59605, despite allowing it in my firewall, it doesn't explain why the proxy and the Chrome web server don't work. Do you have any ideas about that?
    – Timmiej93
    Jul 30, 2020 at 12:00
  • Update: I tried the suggestion in the GitHub issue you mentioned, which does work, oddly enough, even without disabling or allowing anything in the firewall. I can now just go to [mainPcIP]:[port]/index.html and the Brackets Live Preview works fine on my phone. I'm not going to accept your answer just yet, since I'm still stuck on i.e. Chrome Web Server not working. If nobody else has any suggestions, I'll make sure you still get credit for partially solving my issues.
    – Timmiej93
    Jul 30, 2020 at 12:26
  • Assuming when you mention "Chrome Web Server" you're referring to this extension/plugin github.com/kzahel/web-server-chrome, and you have the "Accessible on local network" option enabled, this might help: github.com/kzahel/web-server-chrome/issues/91 Jul 31, 2020 at 14:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .