Total newbie question here. I have a regular Netgear router (COTS) that I am trying to configure to increase the number of LAN IP addresses. Typically, the LAN is setup as follows.

  • IP Address:
  • Subnet Mask:

This setup is great, because I can theoretically get 253 devices hooked up to my router via DHCP. However, I'm hosting an event and might need more about 300 devices (or more) to be serviced. I then changed my LAN setup as follows.

  • IP Address:
  • Subnet Mask:

According to this IP calculator, I can get 510 hosts.

  • HostMin:
  • HostMax:

I then take 2 Windows computers, and

  • set up one computer, A, to be and
  • the other, B, to be

In the GUI, here's the settings for A.

  • IP Address:
  • Subnet:
  • Gateway:

Here's the settings for B.

  • IP Address
  • Subnet:
  • Gateway:

Typically, I would let DHCP dish out the IPs, but in this case, I was just testing to see if A could ping B (on another note, the router can only dish out IPs in the to range, but that might come down to a separate but related DHCP server issue).

A can ping the router at, and B can also ping the router. However, A and B cannot ping each other. Why is this and how do I get A and B to see each other?

  • Are you sure you've set the netmask correctly on both hosts? There shouldn't be any reason for this to not work. Have you tried another private network range - perhaps The "router" should only be operating as a switch between the hosts, so can largely be ignored, though it is odd that A and B can both ping the router, but not each other.
    – Attie
    Jul 30, 2020 at 16:45
  • 1
    Your setup appears to be correct. Having a /23 bit netwask as you have with essentially joins the subnet with so your appreach is correct. However, it is worth noting that I've found many networking devices throughout my career that does not support anything but /8, /16, or /24 bit netmasks, and that could be the case here. Try setting your netmask to and test. Also, have you verified on the computers that the netwosks they get from DHCP are in fact
    – Jarmund
    Jul 30, 2020 at 16:47
  • Disable the firewall on the PCs. Jul 30, 2020 at 17:01
  • Thanks all, the firewall was the problem. I apologize. After I turned it off I can ping. I've since added a GPO to enable PING on all computers for troubleshooting purpose.
    – Jane Wayne
    Jul 30, 2020 at 19:24

1 Answer 1


your configuration is right check if A and B are in same vlan if you have configured, otherwise there cannot be any other reason for this kind of issue according to me, if you find the answer please let me know

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.