Now I use Synology's MR2200AC as my home router and Synology's DS918+ as my NAS for hosting some virtual machines. And I'm trying to connect to the virtual machines from my laptop via a OpenVPN server of VPN plus server app on the Synology MR2200AC.

However, when I'm trying to make a OpenVPN connection to the OpenVPN server, it results in authentication error. But I can success that once in a while. So username and password is correct. The error occurs both the laptop is inside and outside my home LAN.

Current environment of the connection is here.

The laptop is outside my home:
Laptop--Smartphone(tethering)--Internet--MR2200AC--virtual machines(on Synology DS918+)

The laptop is inside my home:
Laptop--MR2200AC--virtual machines(on Synology DS918+)

Laptop:MacOS 10.14.6, with using OpenVPN connect v3.2.1(https://openvpn.net/download-open-vpn/)
MR2200AC:SRM 1.2.4-8081(Internet connection is IPoE(MAP-E))
DS918+:DRM 6.2.3-25426
virtual machines:ubuntu server 20.04 on DS918+'s Virtual Machine Manager app

The OpenVPN connection between the OpenVPN server and the virtual machines is not problem. The virtual machines can always success the authorization and can keep it's OpenVPN connection with the OpenVPN server.

I can make vpn connection with the MR2200AC from outside my home if I use WebVPN function on the VPN plus server app(Not OpenVPN connection). So I have tried to export configuration file from OpenVPN tab on the VPN plus server app when the laptop is outside my home and used the file.
Also I have tried to change udp protocol to tcp protocol, and to launched the OpenVPN APP on the laptop with root priviledge.

But those work once in a while, not always.

I thought the above IPoE(MAP-E) may cause problem. But a DNS configuration of the MR2200AC works correctly.

I can't understand what is wrong.

I'd like to want to build a reliable vpn connection between the laptop and the virtual machines. For example, I access to a mysql server on the virtual machine, whether the laptop is inside or outside my home LAN. In this example, the above WebVPN is useless.

Please help me.

One of Logs for example is here.

7/31/2020, 1:04:33 PM OpenVPN core 3.git::3e56f9a6 mac x86_64 64-bit built on Jul 3 2020 15:36:10
7/31/2020, 1:04:33 PM Frame=512/2048/512 mssfix-ctrl=1250
7/31/2020, 1:04:33 PM UNUSED OPTIONS
1 [tls-client]
3 [pull]
5 [script-security] [2]
7/31/2020, 1:04:33 PM EVENT: RESOLVE 
7/31/2020, 1:04:33 PM Contacting ************* via TCPv4
7/31/2020, 1:04:33 PM EVENT: WAIT 
7/31/2020, 1:04:33 PM UnixCommandAgent: transmitting bypass route to /var/run/agent_ovpnconnect.sock
"host" : "**********",
"ipv6" : false,
"pid" : 35641
7/31/2020, 1:04:33 PM Connecting to [***************]:**** (***********) via TCPv4
7/31/2020, 1:04:33 PM EVENT: CONNECTING 
7/31/2020, 1:04:33 PM Tunnel Options:V4,dev-type tun,link-mtu 1603,tun-mtu 1500,proto TCPv4_CLIENT,keydir 1,cipher AES-256-CBC,auth SHA512,keysize 256,tls-auth,key-method 2,tls-client
7/31/2020, 1:04:33 PM Creds: Username/Password
7/31/2020, 1:04:33 PM Peer Info:

7/31/2020, 1:04:34 PM VERIFY OK: depth=2, /O=Digital Signature Trust Co./CN=DST Root CA X3
7/31/2020, 1:04:34 PM VERIFY OK: depth=1, /C=US/O=Let's Encrypt/CN=Let's Encrypt Authority X3
7/31/2020, 1:04:34 PM VERIFY OK: depth=0, /CN=**************
7/31/2020, 1:04:40 PM SSL Handshake: CN=*****************, TLSv1.2, cipher TLSv1.2 DHE-RSA-AES256-GCM-SHA384, 2048 bit RSA
7/31/2020, 1:04:40 PM Session is ACTIVE
7/31/2020, 1:04:40 PM EVENT: GET_CONFIG 
7/31/2020, 1:04:40 PM Sending PUSH_REQUEST to server...
7/31/2020, 1:04:40 PM AUTH_FAILED
7/31/2020, 1:04:40 PM EVENT: AUTH_FAILED 
7/31/2020, 1:04:40 PM EVENT: DISCONNECTED 
7/31/2020, 1:04:44 PM Raw stats on disconnect:

BYTES_IN : 4993
BYTES_OUT : 2163
⏎7/31/2020, 1:04:44 PM Performance stats on disconnect:
CPU usage (microseconds): 9352624
Network bytes per CPU second: 765
Tunnel bytes per CPU second: 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.