1

I'm try to reproduce the same behavior of my work laptop with my personal computer.

In my work laptop, I'm administrator. There are a few more accounts like ITadmin and similars but my account has admin privileges and I never need to "Run as Administrator" any of my software.

On my personal computer I have a similar setup. Of course I'm admin but I still need to "Run as Administrator" all the programs that requires such permissions.

Both computers have the UAC set to the minimum. What's the magic setting on my work laptop?

1
  • You might be wanting to try the 32-bit DWORD value FilterAdministratorToken Try this tool the "Winaero Tweaker", winaero.com See the "Enable UAC for Built-in Administrator" winaero.com/blog/…
    – vssher
    Aug 3 '20 at 19:09
0

Not magic, just security policy :)

Use User Account Control security policy settings to control how UAC is configured on your computer.

You can quickly navigate to the settings described on the linked page by running this command:

secpol.msc

Then drill down into Security Options to find these policies:

enter image description here

1

Four methods to disable UAC. Note that Microsoft frequently changes its implementation of UAC, so all methods have a limited life time.

Method 1: Disable UAC via Control Panel

(This method doesn't work for the latest versions of Windows 10)

  • Go to Control Panel > User Accounts > Change User Account Control settings
  • Drag the slider control to "Never notify"
  • Click OK.

Method 2: Disable UAC via the Command Line

  • Run Command Prompt as administrator

  • Enter the following command and press Enter:

      reg.exe ADD HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v EnableLUA /t REG_DWORD /d 0 /f.
    
  • Reboot the computer.

Method 3: Disable UAC Group Policy

  • Enter the Policy Editor
  • Click Edit group policy
  • Go to Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options
  • Scroll down to "User Account Control: Run all administrators in Admin Approval Mode"
  • Double-click it
  • Choose Disabled
  • Click OK.

Method 4: Disable UAC Windows 10 Registry Key

  • Run regedit

  • Go to the path:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
    
  • Double-click on EnableLUA and change it to 0.

Not the answer you're looking for? Browse other questions tagged or ask your own question.