I'm losing my mind.

I created a super simple Application in Mac Automator which just runs a one-line Python script and then has a loop action at the end. I ran this and it started working. Then no matter what I tried, deleting the application, killing the process, it doesn't stop.

For one, the PID of the process is constantly changing and the parent process seems to be launchd (1). And I know it's still running because the Python script writes "foo" to a .txt file I have and it's still writing it. I tried rebooting to no success either.

Please tell me how to stop this process..

1 Answer 1


Ok, I solved it. Whoever is interested in what on earth happened here I'll write it down:

I originally had made a LaunchAgent .plist for this very same purpose, but it was not working. So I went the Automator route and it actually began to work. But then it would never end and I assumed it was because of the Automator.

In the automator Run Shell Script action, I had to change the top line of the python script specifying #!/usr/bin/env python3 to use python instead.

Turns out doing this actually got the original LaunchAgent working as well. So the whole time it was not the Automator but this LaunchAgent that was running every time I rebooted etc. With a simple launchctl unload I was able to stop it. (But now I don't want it to stop, cause I have my original idea working! Yay!)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .