0

Some time ago I installed a larger Windows update, I guess also using an external flash medium to have enough space. Since it took some time, I left it running over the night. I think the next morning it had booted into a recovery mode where the default options all did not work. So I did some search on the internet and tried some stuff on the command line. Unfortunately that made things worse and the PC did not boot Windows at all afterwards (not even the recovery mode). All I got was the EFI shell.

I then went ahead and booted from a recovery medium. Apparently the System (EFI) partition is completely empty (I might have formatted it trying things, don't remember). Also the steps I could find on the internet to restore it did not work.

I guess the problem is that the C:\Windows\boot folder is incomplete. Running bcdboot C:\Windows /v (/v for verbose output) I get some error messages for example that C:\Windows\boot\Resources\BOOTRES.DLL and C:\Windows\boot\EFI\bootmgfw.efi do not exist.

Is there an easy way to repair the folder or the System partition (maybe from the install media)?

System information:

  • Windows 10
  • UEFI
  • GPT

1 Answer 1

0

If you have an installation media of windows 10 you can do the following

  1. boot from media
  2. Choose language
  3. Click next
  4. now you should see a button with "Install now". below in the left corner you can find computer repair options (or comparables). Klick on that.
  5. Choose a System Recovery option (normaly windows creates a system restore point before an update)
3
  • 1
    "it had booted into a recovery mode where the default options all did not work." - So I already tried that, but unfortunately the recovery options offered did all not work, I think there was no system restore point for me to choose from, unfortunately. Maybe that has been created on the external media that I used to support the upgrade? However, I don't know which media I used for that and whether that still has the data.
    – clel
    Aug 5, 2020 at 9:38
  • Thanks for the link. I guess that would also have not helped, but not sure. I ended up saving all important data and program settings with a Linux live session on a USB stick and then reinstalling Windows. Not what I hoped for but at least it worked.
    – clel
    Nov 30, 2020 at 20:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.