0

My host computer is running Windows 10 on an i3 CPU.

I've installed VirtualBox with a Windows 10 64 bits guest. The problem is that Virtual Box consum relatively high CPU whilst the guest is idle (see screen shot). I have installed Virtual Box at work and I haven't this problem.

Comparing Host Task manager and guest

1
  • I've allocated the same number of processors (4) of my host to the guest machine and works better now. It's strange because virtual box say "the number of virtual processors allocated to the machine is greater than the number of physical processors on the host". But it works. Why ? I don't know... – Coucout Aug 6 '20 at 16:18
0

Maybe your processor supports AMD-V/VT-x virtualization technologies but it is disabled. If your processor offers it, then boot into your BIOS/UEFI firmware, look for an option like "Enable virtualization technology" and enable it.

Also you may turn of the Nested paging option. Shut down VM, Go to settings > system > acceleration and uncheck Enable Nested paging.

Hope that helps

0

VT-x is of course already turned on. Definitively, the fact to allocate the same number of processors than the host to the guest has resolved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.