0

I tried to install PEBrowse Professional, but the error message below appeared.

ERR

I tried to install the .NET framework online, but the installer said I already have .NET 4.8. How can I resolve this? Thank you for your help!

1
2

I presume Windows 10.
.NET 3.5 is not an install-able program but a subset of .NET 4.0 and higher on Windows 10. But the 3.5 subset is often not automatically enabled. The installer of a program that needs it should enable the feature, but many installers are not really designed very well and don't do it.

To manually enable it: Go to the old-style Control Panel, Section "Programs and Features".
On the select "Turn Windows features on or off".
In the popup-window that now shows up make sure .NET 3.5 is enabled. (Make sure you have a working Internet connection at this point as Windows wants to check for updates to .Net when you enable it.) You may have to reboot as well.

This should convince the program that .NET 3.5 is available.
If that isn't enough complain to the author. The program is not properly detecting the presence of .NET 3.5 (Probably because it uses an old XP-style detection method for .NET version that was depreciated already in Windows 7 and later completely disabled.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.