I am Kali linux user and I want to install Windows 7.

I tried to make bootable USB flash drive in Kali and it failed due unknown reasons. Then I tried to do it with help of Android.

I bought an OTG cable and inserted USB to phone. I copied Windows 7 ISO to phone and tried to make bootable USB using ISO2USB(App on Google Play). I selected my USB drive and ISO file, then pressed to Start. It showed error as:

“Requires Fat32 filesystem USB.”

I changed it to Fat32 using Gparted,then tried again. It loaded till 10% and after this showed error

“Could not write to device, result == -1 errno 0 null”

I tried it several times and decided to format USB using Gparted. But when I wanted to format it, it showed USB drive different:

error N1

I tried create partition table but it showed error again:

error N2

Then I tried to format USB stick on Android too and it not worked too.

I already tried all methods and all failed. How I can turn my USB drive back to useful drive and after this how to make bootable Windows 7 USB flash drive from Kali linux 2019.4?

  • What exactly was the question? Also, please add more info about the linux "unknown reasons". What tools did you use? Did you tried to burn an iso image?
    – GeoMint
    Aug 7, 2020 at 14:07
  • @GeoMint here is your answers: Question:How I can format my USB drive even it shows "Read-Only" error?(I don't have another PC for formatting) Reasons:After UNetBootIn ended process it show a message:"Restart your PC and choose Unetbotin in Bootloader.". I done everything as it said but faced with this error: ***File /boot/ubnkern not found. You need to load the kernel first.***(I chose Hard Drive before Unetbootin done process. And..... Yes I tried to burn iso image but not worked too. Aug 7, 2020 at 14:15
  • So to understand. After doing all that your computer does not recognize the usb when you connect it to linux? Also can you comment a screenshot of your full gparted?
    – GeoMint
    Aug 7, 2020 at 14:20
  • @GeoMint,It doesn't shows it at File Explorer of Kali linux,but shows at Gparted. And.... Comments of Screenshots: I wanted to make a new partition and format USB drive again but couldn't due Gparted looked like this and showed error when I wanted to format it.(I couldn't understand why it shows like this.) Aug 7, 2020 at 14:25
  • what info about USB drive is shown in gnome disk utility ? Attach a screenshot . Also add outputs of : sudo gdisk /dev/sdx . Also as a note use woeusb github.com/slacka/WoeUSB to create bootable windows usb from linux.
    – Madhubala
    Aug 7, 2020 at 16:48

2 Answers 2


Since you can't find a solution with Gparted i suggest using fdisk.

Run as sudo:

fdisk -l # Make sure your device address is correct
mkfs.vfat /dev/sdc # format into Fat32 ( assuming /dev/sdc is the device you wish to format )
  • Not works :( It shows mkfs.fat 4.1 (2017-01-24) mkfs.vfat: unable to open /dev/sdc: Read-only file system Aug 7, 2020 at 14:39
  • Try umount /dev/sdc
    – GeoMint
    Aug 7, 2020 at 14:41
  • It shows umount: /dev/sdc: not mounted. (I guess it means that USB already unmounted.) Aug 7, 2020 at 14:43
  • 1
    You must have 20 reputation on The Stack Exchange Network to talk here. Aug 7, 2020 at 14:50
  • No worries. Can you run hdparm -r0 /dev/sdc ? you might to install it first
    – GeoMint
    Aug 7, 2020 at 14:52

Finally,I done it. I don't need Kali for now so,I used one trick(Do this trick if there is no other ways). I made a volume using gparted and used that volume as bootable device. Then I found a program: python3-multibootUSB.It helped me to make that volume as bootable device.Chose that volume and ISO file and Done!

Rebooted device.After reboot I saw Windows Rescue Mode at Grub. I chose that option and started setup of Win7. Then installed and done! I not tried to solve USB drive's problem yet but I guess Diskpart will work.

Note:After installation you will not able to access the volume that you made for booting.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .