1

I have a software that will use a certain file from a local SHARE FOLDER which the folder was previously created between two connected computers through LAN cable. However, one of the PCs did not directly detect the files inside the folder and still consider the folder to be empty although the file is already available (another PC detected the file). This cause my software to fail the running process.

I have some other share folder between these two PCs and none of them faces the this issue. If I just let open the folder on the PC, then the file is able to be detected by the PC, but I guess this is not the best practice.

Can anyone help on this?

4
  • Run Computer Management > System Tools > Shared Folders > Shares. Right-click the share, select Properties, then in the General Tab click Offline Settings. Set the option "No File or Program's From the Shared Folder are Available Offline" and click OK. Perhaps reboot is required. – harrymc Aug 8 '20 at 17:32
  • there are no Properties when I right-click on the Shares thus I dont find any "No File or Program's From the Shared Folder are Available Offline" option. Can you clarify more on this? – Winter Bucky Aug 9 '20 at 8:45
  • Click on Shares on the left and you will see the list of all shares on the right. Right-click on the right the share in question. – harrymc Aug 9 '20 at 8:52
  • I added an answer with an illustration. – harrymc Aug 9 '20 at 9:49
0

When you access a shared folder in another location, Windows allows the option to make the files available offline. This means that even when you are not connected to the other location, your local folder contains the latest copies of the files.

From your description, the folder in question was set up this way. Therefore until you open your local folder, its contents remain as they were the last time you opened it.

If you need your folder to always refer to the remote folder, you can turn off this "offline files" feature by right-clicking the local folder and deselecting Always available offline:

enter image description here

If you do not see Always available offline in the context menu, look under Properties instead, where it may be on the Offline Files tab:

enter image description here

Alternatively you may manage offline files in Sync Center (Control Panel\All Control Panel Items\Sync Center)

enter image description here

Once your folder is set by one of the above means to Always available offline, and once Windows has done a resync in line with this setting, the folder will always reflect the remote folder contents.

2
  • can I know where can I select the "Always available offline" option? Normal right click on the share folders does not have this selection. – Winter Bucky Aug 9 '20 at 8:46
  • @WinterBucky I've updated my answer to show some alternative ways to get to the setting if it's not showing up in the context menu. – Reg Edit Aug 9 '20 at 20:56
0

The folder might be kept for offline browsing on the computer, so its contents are not being updated.

To disable caching:

  • Run Computer Management > System Tools > Shared Folders > Shares, the list of shares is displayed on the right
  • Right-click the share in question and select Properties
  • In the Properties dialog, General Tab, click Offline Settings ...
  • In the Offline Settings dialog, set the option to "No files or programs from the shared folder are available offline"
  • Click OK all the way

A reboot might be required.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.