0

I tried out zsh, but decided to revert to bash because it's what I'm used to. I've set my "Login shell" back to /bin/bash in System Preferences > Users & Groups > Advanced options and have run chsh -s /bin/bash. When I run echo $SHELL I get the expected "/bin/bash" output. However, the top of my terminal windows says " - ZSH - bash" and when I force an error, like searching for something that doesn't exist, the message seems to indicate that it's still running zsh: zsh: no matches found: *test

I've tried to force it to be bash in every way I know how. What am I not thinking of? Any/all suggestions appreciated.

Edit: When I go to close the shell, here's what I see (it says it needs to terminal ZSH). enter image description here

Edit 2: When creating a new window I got this message, which is new. Setopts is in my .bashrc file, so it seems to be set to zsh in whatever is loaded after the .bashrc. The top text has now changed back to the default, so I guess ZSH is no longer the "Active process". enter image description here

10
  • What version of macOS are you using? I don't see any "Advanced Options" under System Preferences > Users & Groups. Aug 14 '20 at 9:02
  • 1
    Check Terminal > Preferences > General > Shells open with.
    – harrymc
    Aug 14 '20 at 9:27
  • Check with grep $USER /etc/passwd the last field (with the used shell).
    – Hastur
    Aug 15 '20 at 8:08
  • Advanced Options appears if you unlock w/ a password and then right-click. "Shells open with" is set to "Command: /bin/bash". Nothing is printed by "grep $USER /etc/passwd". Thanks for trying, all! :)
    – GenesRus
    Aug 15 '20 at 17:27
  • 1
    Try doing chsh -s /bin/bash USERNAME and sudo chsh -s /bin/bash. Check for suspicious dot-files ~/.z* and others including ~/.profile.
    – harrymc
    Aug 18 '20 at 8:13
0

The fact that "ZSH" in the window title is in all caps leads me to believe that this is your problem:

screenshot of MacOS Terminal's Preferences window showing the window title setting for the default profile

To see if this is it:

  1. Launch Terminal
  2. Go to Preferences
  3. Go to the Profiles tab
  4. Select the profile marked "Default" in light gray text below its name
  5. Go to the Window tab
  6. I believe you'll find the text "ZSH" in the Title field. Change it to "waffles and ponies!" or whatever you'd like to see there instead.

These instructions are based on macOS 10.15.6 Catalina. YMMV.

6
  • I agree - given that there is bash after ZSH in the title, just as if that is the process running. Not sure how ZSH came to be the title for Terminal if this was the case...perhaps another application changed this...somehow?
    – QuickishFM
    Aug 20 '20 at 21:49
  • Unfortunately, the "ZSH" appears to actually be the "Active process name", not the title (which has always been "Terminal" when I checked it). The "bash" is "Shell Command Name".
    – GenesRus
    Aug 21 '20 at 0:16
  • @GenesRus does your Bash rcfile or profile invoke zsh?
    – JakeRobb
    Aug 21 '20 at 22:00
  • No, I've checked that both are clean. My .bash_profile just sources the .bashrc, which sets PATH, some other environment variables, and a bunch of aliases. I wish it were that easy. :)
    – GenesRus
    Aug 25 '20 at 19:37
  • Could you please open a brand new Terminal window, type ps -f, then append the complete contents of that terminal window to your question?
    – JakeRobb
    Aug 25 '20 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.