0

We have a bunch of workstations installed on CentOS 7.4. We want to start implementing the switch to CentOS 8 but it's already not going as planned.

First, I generate my usb installation with this command:

sudo dd if=/path/CentOS-8.2.2004-x86_64-dvd1.iso of=/dev/sdc

And I've verified the checksum of the iso.

From the CentOS installation menu, we choose Install Centos 8.2... and no matter what type of installation we choose (EFI or Bios), we always get the following error:

dracut-pre-udev[885]: modprobe: FATAL: Module floppy not found in directory /lib/modules/4.18.0-193.el8.x86_64
dracut-pre-udev[885]: modprobe: ERROR: could not insert 'sha256_mb': No such device
[ ok ] Started Show PLymouth Boot Screen.
[ ok ] Started Forward Password Requests to Plymouth Directory Watch.
[ ok ] Reached target Local Encrypted Volumes.
[ ok ] Reached target PAths.

And then nothing else ever happens even if the machine still on.

However, if in the CentOS installation Menu, we choose Troubleshooting and then Install CentOS Linux 8 in basic graphics mode, we are able to perform the installation.

How could we solve this? We need to be able to run basic installation for the deployment, previously done with tftp and kickstart.

EDIT: Increasing log level to debug doesn't provide any additional log.

2
  • add modprobe.blacklist=floppy to the kernel options
    – Madhubala
    Aug 10, 2020 at 15:56
  • Adding this by pressing tab on the installation menu entry didn't work. It's what I was suppose to do, right? Thanks anyway. Aug 11, 2020 at 7:36

1 Answer 1

0

I had the same issue and same error message, this seems related to fips. Adding fips=0 on kernel command line fixed it in my case.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .