I recently installed Windows 7 Professional 64bit on a new machine. I installed an application using a ClickOnce installer.

The application runs fine, but I cannot access the application folder it created in c:\Program files (x86). It bombs with access denied. I try to view the properties on the folder and it takes about 1 minute to display (other folders take 1 second). It says I cannot view any information because I'm not the owner. It doesn't say who the current owner is (instead - Unable to display current owner.) but says I can take ownership. When I try it fails again with Access Denied, even though I have administrative permissions.

Why can't I access this folder nor take ownership?

  • How have you tried to take ownship? You have to do it from the command prompt – D'Arvit Jun 28 '10 at 16:12
  • You probably had to install the program with higher user privileges than your own and now aren't able to access the files because they belong to admin. Try the takeown command: technet.microsoft.com/en-us/library/cc753024%28WS.10%29.aspx Remember to run the command as admin. – D'Arvit Jun 28 '10 at 16:13
  • Thanks, I tried from the Windows GUI - access denied. I tried from the command prompt with takeown - access denied. Tried again with runas /user:administrator, another console opens up and displays for 0.5 seconds and then disappears so I can't read it. When I check in Windows Explorer I still do not have ownership. My user account is part of Domain Admins. Under Windows XP I didn't have to do anything special because I already had administrative rights. Any other ideas? – GiddyUpHorsey Jun 29 '10 at 6:47
  • 1
    You need to use runas /user:Administrator cmd, then run takeown from that. – Hello71 Sep 3 '10 at 1:58
  • Open the command prompt with "run as administrator" – Moab Jan 10 '11 at 2:52

You can try to install this reg tool that adds a "take ownership" to windows explorer right click menu, and take back the ownership of your folder.

Or, maybe it can be a problem in your disk. It the above solution does not work, try to run a CHKDSK /f in your C: drive.

  • Just use the takeown command – D'Arvit Jun 28 '10 at 16:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.