0

I am using ClamAV antivirus on Fedora 32. If I will run scan of whole system for malicious file, clamd is runned as user clamscan. Problem is, that user clamscan has not permission for reading any files (ClamAV is finishing with errors). I am not very familiar with user permissions and things about this. I tried to add clamscan to /etc/sudoers as root by adding this line

clamscan ALL=(ALL) ALL

However this user still doesn't have permission. I am also not sure if this solution was a good idea (make clamscan as root user).

Could someone help me, how could I add permission for reading to this user? Thank you in advance.

1 Answer 1

0

Putting a user in /etc/sudoers tells suso what that user can do. It doesn't automatically make all proccesses for this user run as root.

It was also not a good idea: it allows the user clamscan to do everything on your system, but it does not solve your problem.

If your clamd needs to read every file on the system, it should run as root, not as clamscan.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.