I have a really weird issue a TESmart HDMI KVM switch. Because you don't want the mouse to be seen as plugged/unplugged every time you switch devices, it has a special USB input for your mouse and then emulates an always-connected mouse for each device.

However, this emulated mouse appears to completely ignore the OS mouse sensitivity settings. I would have thought that the OS handles all of the sensitivity curves and whatnot - surely the mouse just sends raw data and this is handled at the driver level. But I get the exact same behaviour on Mac and Windows! I can change the mouse sensitivity but the setting is completely ignored. It is just stuck on "slightly too fast".

If I plug the mouse in it works perfectly. So my question is:

When using HID USB mice, are sensitivity settings actually sent to the mouse and handled by the mouse? If not how can this possibly be an issue on both Mac and Windows?

2 Answers 2


Ah I just figured it out! This KVM has a "fast switching mode" where you can hit the side of the screen with your mouse twice to switch inputs. Somehow this got turned on. (It also explains why it was randomly switching inputs without me asking!)

As soon as you turn it off (Scroll lock, Scroll lock, F12), the mouse works perfectly again. My guess is that in order to know when you hit the side of the screen, the KVM has to be in charge of the position of the cursor on the screen, so it must set the mouse to absolute mode, and then the OS sensitivity has no effect.


i've got the same issue with my Delock 11484 DP 1.4 KVM switch. I haven't found a way to disable the mouse gesture for switching ports (move the Cursor to the edge of the screen and continue moving the mouse away from the screen for 2 secs). My solution is not to use the dedicated mouse console USB port but instead one of the USB Ports that are meant to be used for other peripherals. I've only tested Windows 10 so far, it works great. Mouse gesture doesen't work anymore, but that's great for me.

  • Thank you! 🙏😭
    – Manolis
    May 12 at 11:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .