I have a dual boot Windows Vista Basic/Ubuntu KDE4 compaq laptop.

when I have put the laptop into hibernation from windows I sometimes find that it will turn itself back on.

Any ideas what causes it to come out of windows hibernate?


Try these lines in cmd prompt

powercfg /devicequery wake_armed

That will give you a list of devices that can wake up your computer. To disable that, type the following

powercfg /devicedisablewake "Name of device goes in here"

For examples:

powercfg /devicedisablewake "Realtech(R) Gigabit Network Adaptor"

  • Make sure you run cmd prompt as administrator – Keith Jan 13 at 3:35

You might want to look at this question on ServerFault

I tracked the culprit down in the past with the command line tool:

powercfg -lastwake

  • Mine says history 0, but over night my laptop turned on while the lid was closed, did a full windows update and then just sat around waiting for me. This is also happening on my desktop machine.. I thought it was wake on lan, cmos settings... now its on my laptop.. cant figure it out – Piotr Kula Dec 15 '15 at 10:18
  • @ppumkin are you on Windows 10? - I've found this command is less useful on Windows 10 – Rowland Shaw Dec 15 '15 at 10:19
  • Yes, Windows 10 – Piotr Kula Dec 15 '15 at 10:19

Hibernation actually turns off the power in the same way shutting down does. The difference is that hibernation stores the state of the machine first. So if you laptop is turning on by itself from hibernation, then something is either pressing the power button or your power button is defective, and will make contact from just jostling it or something.

E: there is another possibility. If your laptop supports Wake on Lan and your laptop is plugged into a network (with a physical cable), then something may be sending it the signal to wake up, which can bring your computer out of hibernation (and even from being powered off).

And if you are talking about standby, which is not the same as hibernate, then Axxmasterr's answer seems like a good possibility. Another potential cause is if the keyboard is being pressed or the mouse trackpad is being activated somehow.


My case i got the answer with following commands -

C:\Users\windows>powercfg -devicequery wake_armed

HID Keyboard Device
(006) Logitech HID-compliant Cordless Mouse (001)

So it was the cordless mouse which was waking it up whenever i forget to switch off the mouse. A shake or push somewhere around the mouse by any of the family member in my absence was sending the signal to the laptop to wake up from hibernation.

Also this is nicely described in the following article - http://www.howtogeek.com/122954/how-to-prevent-your-computer-from-waking-up-accidentally/

I just went to the listed devices in 'device manager' and unchecked the option which allowed these devices to bring the pc out of hibernation.


There are a few options mentioned that can cause the Issue.

Scheduled programs have the possibility to wake the computer if they need to run, this can happen if you schedule recordings in MCE for example.

Faulty hardware such as the mentioned lid switch or eratic mouse behavior can also bring the computer out of sleep mode.

Depending on your usage scenario you can disable most options to wake the computer. You can disable Wake on lan/ring/keyboard/mouse in BIOS. You can change Vistas power settings to not react to the lid switch. This leaves you with only the powerbutton/start menu to sleep/wake your computer.

Doing these steps in any order might help you figure out what's causing the issue or doing all steps might be an acceptable solution in your case.


My guess is the switch that determines the screen is closed is malfunctioning. If this switch goes bad it might think you are opening it back up and of course it comes back to life as default behavior when in standby mode.


Hey to anyone reading this in 2016 Make sure you run powercfg -lastwake after you have experienced the 'waking up' issue, rather than after rebooting because that will clear the log. So when it wakes up run that command and it will tell you what woke it up.

I turned out to be something called TorrentsTime media player in program files in my case so I uninstalled it and now no longer have the problem.

  • Welcome to Super User! This duplicates another answer and adds no new content. Please don't post an answer unless you actually have something new to contribute. – DavidPostill Feb 11 '16 at 15:47

In the case of Windows 10 it's because of the enforced 'updates'. When W10 wants to update and alter it's settings, it will do so, including by starting and restarting by itself. The only way to make sure you prevent that is the old classic complete shutdown.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.