0

I was troubleshooting SMB shares on a Windows PC being inaccessible by an Android TV device (Nvidia Shield TV) when I discovered that it likely was not a SMB/sharing issue, because the Nvidia device was not even pingable by the PC.

All devices on the network have static IP addresses:

  • the router is 192.168.1.1
  • the PC is 192.168.1.2 (hard-wired)
  • the Nvidia is 192.168.1.3 (hard-wired)

The PC can't ping the Nvidia, and the Nvidia can't access SMB shares on the PC, but both devices have internet access and both are pingable by a third device on the same LAN, an Android phone.

When the Nvidia is pinged by the PC, it gets the following output:

Pinging 192.168.1.3 with 32 bytes of data:
Reply from 192.168.1.2: Destination host unreachable.
Reply from 192.168.1.2: Destination host unreachable.
Reply from 192.168.1.2: Destination host unreachable.
Reply from 192.168.1.2: Destination host unreachable.

Ping statistics for 192.168.1.3:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

For troubleshooting, I have tried turning off the Windows firewall and tried removing the static IP from the Nvidia device. I have also tried using a different IP for the router and the LAN devices.

All of this started occurring after replacing the router today.

Why would two devices on the same LAN not be pingable by each other but remain pingable by a third device (and have working internet access, which means their IPs are valid)? How would you troubleshoot it further?

Edit: To troubleshoot further, I have disabled the SPI Firewall in the router along with the following features:

  • APR Spoofing Protection
  • Block Anonymous WAN Requests (ping)
  • Filter Multicast
  • Filter IDENT (Port 113)

The issue still persists.

1

This is a sticky problem.

Realise that there is more then 1 ping protocol, and some ping protocols may be blocked but not others. I would start by putting a switch/hub between the PC and smb system which, assuming the netmasks are correct ( which is likely I think) it will rule out the router [or confirm the problem is there] as lan traffic won't go through it unless the devices are connected to its lan ports.

I would also use tcpdump on the smb box and see if it is receiving the ICMP packets, and check the firewall on it.

I might also try other ping tools (ie try UDP and ICMP based ping)

Another thing I would do is do some pings and then examine the ARP tables on each device to see if the others Mac address is there.

  • Thanks. I tried disabling Ethernet on the Nvidia device and connecting to the router via wifi, and it locates the SMB shares on the Windows PC (which remained hard-wired) and becomes pingable when on wifi. Something else is the culprit that I can't figure out. Buying a switch/hub for testing purposes would be an overkill, because the whole point of this is to salvage an old router. If it's not fixable, I'll just buy a new router. One thing I will try is to get rid of DD-WRT and replace it with some other open-source firmware. Maybe it will start working under different software. – Dave Aug 17 '20 at 11:04
  • Actually, it looks like Tomato does not support Atheros-based routers, so my only option is to go back to stock firmware. – Dave Aug 17 '20 at 11:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.