0

So I need to connect to an SFTP server that only whitelisted an IP Address of a remote machine I have access to (call this machine mysafeserver).

So to connect to the SFTP Server I run:

ssh mysafeserver
> sftp -P 10023 myuser@myremoteserver.com
...

The inconvenience here is I need to access this server a lot, and uses a dual-key authentication process (that is private key and password) so is very annoying doing this through the command line.

In most cases I use Filezilla, but Filezilla does not give me the option to SSH proxy through mysafeserver.

My question is, is there a client other than Filezilla that supports this, and if not, what is the easiest way to set up a tunnel, such that Filezilla can access this server.

I am aware of the ssh command, but this seems to involve port mapping stuff which I'm not sure is exactly what I am looking for.

Thanks

0

I'm not aware of another client that can handle multi-hop connections like this. It seems like some form of tunnel/proxy is required here.

ssh -L10023:myremoteserver.com:10023 mysafeserver

At this point, perform your authentication, and leave the shell session running. Perhaps use the "read" command to have the shell wait for input, if the shell is set to logout on idle.

Then in Filezilla, connect to localhost on port 10023 as if you were connecting to myremoteserver.com. Filezilla will be challenged by the authentication on myremoteserver.com.

0

Yes! There is an option that I was told about yesterday. I'm not good at this stuff but it worked like a dream. Using OSXFuse you can mount your double-hop remote server as a volume (which you can call anything) on Finder (in the example below I call it VOLNAME).

To do this.

1)Install OSXFuse

2)Install sshfs

then you can mount your remote directory locally using

sshfs -o ssh_command='ssh -t USERNAME@MYSAFESERVER ssh' -o volname=VOLNAME -o defer_permissions USERNAME@REMOTESERVER:PATH_TO_REMOTE_DIRECTORY PATH_TO_LOCAL_ MOUNT

replace all the bits in capitals with your information and you are away.

I find sometimes when I start up again the mount gets lost and you have to unmount it again using

umount PATH_TO_LOCAL_MOUNT

but after you've mounted it once that is solved by putting the two commands together in one .sh file that you can call.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.