0

I'm getting no sound (dummy sound) from speakers on my freshly installed Mint Mate. I looked up and applied most popular solutions found online, but could not get it to work. Drivers are up-to-date, when looking into system mixer, the volume seems to be displayed, but still no sound. In amixer, all values are set to '0', yet no sound (see below). I also tried unmuting via command line, but no luck. I'm currently unable to plug in any headphones into the port, so can't tell if it works.

Maybe some of you have an idea, as to what to do next?

These are my specs, if you need more, just let me know what command is to be typed in, and I'll get back ASAP with the answer.

Cheers

lspci -v | grep -i audio

00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)

Subsystem: ASUSTeK Computer Inc. NM10/ICH7 Family High Definition Audio Controller

amixer

Simple mixer control 'Master',0

Capabilities: pvolume pvolume-joined pswitch pswitch-joined

Playback channels: Mono

Limits: Playback 0 - 87

Mono: Playback 60 [69%] [-20.25dB] [on]

Simple mixer control 'Headphone',0

Capabilities: pvolume pswitch

Playback channels: Front Left - Front Right

Limits: Playback 0 - 87

Mono:

Front Left: Playback 0 [0%] [-65.25dB] [off]

Front Right: Playback 0 [0%] [-65.25dB] [off]

Simple mixer control 'Headphone Mic',0

Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive

Capture exclusive group: 0

Playback channels: Front Left - Front Right

Capture channels: Mono

Limits: Playback 0 - 31

Mono: Capture [off]

Front Left: Playback 0 [0%] [-34.50dB] [off]

Front Right: Playback 0 [0%] [-34.50dB] [off]

Simple mixer control 'Headphone Mic Boost',0

Capabilities: volume

Playback channels: Front Left - Front Right

Capture channels: Front Left - Front Right

Limits: 0 - 3

Front Left: 0 [0%] [0.00dB]

Front Right: 0 [0%] [0.00dB]

Simple mixer control 'Speaker',0

Capabilities: pvolume pswitch

Playback channels: Front Left - Front Right

Limits: Playback 0 - 87

Mono:

Front Left: Playback 87 [100%] [0.00dB] [on]

Front Right: Playback 87 [100%] [0.00dB] [on]

Simple mixer control 'PCM',0

Capabilities: pvolume

Playback channels: Front Left - Front Right

Limits: Playback 0 - 255

Mono:

Front Left: Playback 255 [100%] [0.00dB]

Front Right: Playback 255 [100%] [0.00dB]

Simple mixer control 'Capture',0

Capabilities: cvolume cswitch

Capture channels: Front Left - Front Right

Limits: Capture 0 - 31

Front Left: Capture 19 [61%] [12.00dB] [on]

Front Right: Capture 19 [61%] [12.00dB] [on]

Simple mixer control 'Auto-Mute Mode',0

Capabilities: enum

Items: 'Disabled' 'Enabled'

Item0: 'Enabled'

Simple mixer control 'Internal Mic',0

Capabilities: cswitch cswitch-joined cswitch-exclusive

Capture exclusive group: 0

Capture channels: Mono

Mono: Capture [on]

Simple mixer control 'Internal Mic Boost',0

Capabilities: volume

Playback channels: Front Left - Front Right

Capture channels: Front Left - Front Right

Limits: 0 - 3

Front Left: 0 [0%] [0.00dB]

Front Right: 0 [0%] [0.00dB]

Simple mixer control 'Loopback Mixing',0

Capabilities: enum

Items: 'Disabled' 'Enabled'

Item0: 'Disabled'

1 Answer 1

0

Thanks to the magnificent Discord user mys31f the sound is ON!

It takes only one command, that they found on some very old forum post:

sudo alsactl init

The problem is that I need to input it after every reboot.

So...

Because of the need to init alsa every time after reboot, i Kept on looking for answers.

on forums.linuxmint.com I found a couple of related posts, and one user popped out: MrEen. He has a lot of knowledge on the issue of missing sound, that he compiled into a set of Fix Tips. However, nothing from that list seemed to be a solution to my problem, so I asked him personally, and that's the thread.

Basically ALSA seems to not store the settings, so one needs to manually save them in a config file.

That's it. It works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.