2

For some bizarre reason, Firefox ESR 68.0 running on Debian Linux shows Windows 10 as its user agent when inspected in help>troubleshooting information.

Mozilla/5.0 (Windows NT 10.0; rv:68.0) Gecko/20100101 Firefox/68.0

The about:config lacks overrides by default, but general.useragent.override and its enable are both added. No specification given here makes any difference. No user agent entry shows by default, and certainly nothing specifying the Windows 10 string.

Where on earth is user agent even being given?

The Firefox I am running is downloaded directly from the mozilla site, and is not a native Linux package.

Nothing can be found of this oddity in web searches.

Have Mozilla changed their user agent policy? The Mozilla support pages still provide the usual old useragent override solution, which I thought was widely used by web developers anyway.

By contrast, the User Agent Switcher extension does successfully change UA, and will fool any website tested.

1
  • I'm having the same problem; would love somebody to answer this.
    – Barra
    Jun 20, 2022 at 17:17

1 Answer 1

0

Disable privacy.resistFingerprinting in about:config. In my firefox in Ubuntu, it turns from Windows 10 to Ubuntu when I disable it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .