5

I'm trying to get:

start "" /high "c:\software\mysoftware.exe"

or

start "" /realtime "c:\software\mysoftware.exe"

To work on Windows 10. Which I of course can't, as determined through threads like: start /realtime with a .bat file but the process is still not realtime

In it however, the user is trying to get a program to start with high priority, on Windows start. Whereas I, would like to start it arbitrarily. There, the thread was solved by using Task Scheduler.

So my question is, if a similar alternative or workaround can be used, to run software arbitrarily, with a higher priority than normal…

Now I know there are a lot of threads on this out there, but most of them either don't fit the use case or just don't work. Like the one here: Start process in high priority

I tried:

start "Frozen Throne" /high "C:\Users\Valeri\Saved Games\Warcraft III\Frozen Throne.exe"

As in the first answer, and it just didn't work…

I'm curious about the solution in: Run a file with HIGH priority

But can anyone give some feedback on how I would apply something like that, to my scenario? Any feedback on solving this absolute blunder from Windows, would be greatly appreciated...

EDIT 1: One of the users suggested I use start /b /High "c:\software\mysoftware.exe", which I did in the past, to no avail, and tried again just now. What happens is that the application doesn't launch at all and I just get this, inside of CMD: enter image description here

EDIT 2: I tested start "" /high notepad, as mentioned in @harrymc's post, and the Notepad did indeed, open up with high priority, however, this and all other attempts, do not seem to work at all for C:\Users\Valeri\Saved Games\Warcraft III\Frozen Throne.exe, which I want to open as either realtime or high

FINAL EDIT & SOLUTION: So as it turns out, I haven't been too attentive after all, as launching C:\Users\Valeri\Saved Games\Warcraft III\Frozen Throne.exe, automatically opens up war3.exe instead...

Applying start "" /b /High "C:\Users\Valeri\Saved Games\Warcraft III\war3.exe" as recommended by @DavidPostill or

Start-Process "C:\Users\Valeri\Saved Games\Warcraft III\Frozen Throne.exe"
Get-WmiObject Win32_process -filter 'name = "Frozen Throne.exe"' | foreach-object { $_.SetPriority(256) }

, as recommended by @Steffen S., to the right .exe, that may open after the initial .exe in some cases, solves this issue... thanks for all the help!

4
  • You should use /b switch like this : start /b /High "c:\software\mysoftware.exe"
    – Maria
    Commented Aug 22, 2020 at 18:32
  • @MitraM Thank you for you comment! I did try this in the past and just tried it again, but unfortunately, to no avail... I've included an edit regarding this, in the bottom of the thread Commented Aug 22, 2020 at 18:43
  • That should be start "" /b ...
    – DavidPostill
    Commented Aug 22, 2020 at 19:54
  • @DavidPostill Thank you David! Just tried start "" /b /High "C:\Users\Valeri\Saved Games\Warcraft III\Frozen Throne.exe", but still 'Normal' inside of Task Manager, unfortunately... Commented Aug 22, 2020 at 20:14

4 Answers 4

3

You should be able to change the process prioriy after starting the application with PowerShell. Be aware that 'Realtime' requires the PowerShell command to be run with adminstration rights. If you don't priority will be set to "High" instead.

Get-WmiObject Win32_process -filter 'name = "Frozen Throne.exe"' | foreach-object { $_.SetPriority(32768) }

So a complete ps1-file could look like:

Start-Process "C:\Users\Valeri\Saved Games\Warcraft III\Frozen Throne.exe"
Get-WmiObject Win32_process -filter 'name = "Frozen Throne.exe"' | foreach-object { $_.SetPriority(256) }

Reference: SetPriority method

6
  • Thanks so much for your reply! Just tried this solution, but it seems that the priority is still set to 'Normal', when I inspect the process later, within Task Manager... did run the PowerShell elevated, but yeah... Commented Aug 22, 2020 at 19:45
  • Sounds like the process is not ready, maybe a "Start-Sleep -s 10" in between helps?
    – Steffen S.
    Commented Aug 22, 2020 at 23:23
  • Gotcha. I've tried: Start-Process "C:\Users\Valeri\Saved Games\Warcraft III\Frozen Throne.exe" Start-Sleep -s 25 Get-WmiObject Win32_process -filter 'name = "Frozen Throne.exe"' | foreach-object { $_.SetPriority(256) } but it didn't quite help either, unfortunately... Commented Aug 23, 2020 at 9:10
  • That's strange, can you try starting the game and then use the Get-WmiObject command in the PowerShell?
    – Steffen S.
    Commented Aug 23, 2020 at 9:18
  • 1
    This didn't help either, but I noticed a crucial thing here, looks like it was my bad all along... when 'Frozen Throne.exe' is opened, it automatically opens 'war3.exe' instead. Applying the aforementioned to 'war3.exe', solved this. Thanks so much for your help Steffen! And... please forgive my obtuseness... Commented Aug 23, 2020 at 9:28
2

The standard method works fine for me, so I wonder what are the differences between your setup and mine.

I have started CMD as Administrator and ran the following, in addition to starting notepad normally:

enter image description here

The results are as predicted by the documentation:

enter image description here

Some product or other restriction might be blocking the correct functioning of the start command on your computer. Try testing while booting in Safe mode, to disable all non-Microsoft programs and drivers.

It could also be some property of your program that is preventing this, or perhaps your antivirus or another security software.

5
  • Thanks for your reply Harry. I tired running start "" /high notepad on my machine, and it did indeed, open up as high, when inspecting through Task Manager. However this doesn't quite work, for the .exe I'm trying to open, which is very strange... by the way, I don't seem to have 'Base priority' in my Task Manager, tried looking in View and such, but to no avail... Commented Aug 22, 2020 at 20:36
  • For 'Base priority', in Details view right-click the column headers, click Select columns, place a check-mark next to it and click OK.
    – harrymc
    Commented Aug 22, 2020 at 20:52
  • oh yeah, my bad, sorry Commented Aug 22, 2020 at 20:56
  • It might be that Frozen Throne.exe is fighting you in this case, reducing its own priority. You might alternatively be interested in Game Mode, although it doesn't work for all games.
    – harrymc
    Commented Aug 22, 2020 at 20:58
  • hm, not too sure about that. It works just fine when I set the priority manually... looks like I have Game Mode on already, didn't know about this setting before though, thanks Commented Aug 22, 2020 at 21:07
1

I just used this for fixing lagging in a live DAW, Gig Performer:

Start-Process "C:\Program Files\Deskew Technologies\Gig Performer 4\GigPerformer4.exe" Get-Process -Name "GigPerformer4" | ForEach-Object { $_.PriorityClass = "RealTime" }

The other methods weren't working, I am using Windows 11.

-1

After testing and testing and testing, the simplest solution for all kinds of processes including games (the 'start' method didn't work) is to use 'process hacker' and save the priority once changed... Simple and effective !

2
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Sep 8, 2022 at 21:01
  • Please read How do I recommend software for some tips as to how you should go about recommending software. You should provide at least a link, some additional information about the software itself, and how it can be used to solve the problem in the question.
    – DavidPostill
    Commented Sep 9, 2022 at 5:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .