6

Using Microsoft Teams, I get ugly purple no-padding notifications on my Desktop:

Microsoft Teams Notification

How can I force Microsoft Teams to use the operating system's default notifications UI instead?

  • macOS Notification Center
  • Windows 10 Notifications
9

There seems to be a development option enableNativeNotification that will enable system notifications in Microsoft teams. I unfortunately cannot try this myself, as the development preview needed to enable the option is not enabled for my organization.


Information taken from this Reddit post which provided these screenshots.

FWIW for anyone frustrated at the custom notifications, you can enable Native Notifications by throwing Teams into developer mode and then left clicking the Teams tray icon 7 times. Right clicking will then give you tons of options, including Hooks. From here, you can enable Native Notifications (defaults to false, so turn it to true) and voila, native notifications.


The steps seem to be:

  1. Enable the Public Developer Preview for Microsoft Teams
    • Note: Developer preview is enabled on a per-client basis, but the option to turn on developer preview is controlled at the organization level.
  2. Tap on your app icon 7 times to enable the dev tools:
    • Windows: System Tray icon
    • macOS: Dock icon
  3. Access the Developer Preview tools:
    • Windows: Right-click the System Tray icon. Select Open DevTools.
    • macOS: select "Development" from the app's main menu bar. You can also edit the settings directly at ~/Library/Application\ Support/Microsoft/Teams/settings.json
  4. Set the following options to true: enableNativeNotification, enableMacNativeNotification
  5. Restart Microsoft Teams

If all goes well, Teams should then use the system's native notification system:

enter image description here

3
  • Just an FYI on macOS, after you've enabled enableMacNativeNotification and enableNativeNotification, you still might have to go in the Teams settings, and switch it to Mac. – BeryJu Feb 22 at 14:53
  • 2
    Confirmed this is working on macOS Big Sur. A couple of things that got me: 1) it wasn't clear that these settings are under the "Hooks" submenu under the Development menu, and 2) setting enableMacNativeNotification via the menu did not work for me - I still had to open settings.json and set it there - then I was able to restart, and go into settings and set notification style to Mac, after which I was prompted by the OS to allow teams notifications. – Cory W. Feb 24 at 19:36
  • This doesn't work for me. There's no settings whatsoever accessible via the development menu, and changes to the settings.json are reset after restarting Teams. Have to wait I guess... – Moritz Friedrich Apr 7 at 8:08
3

There is currently no non-beta way to use OS-native Notifications in Microsoft Teams.

The Teams development team is supposedly testing and/or adding this feature. The tickets, created in 2016, have been updated in December 2020 indicating that the feature will be released in early 2021.

These requests are tracked on the Microsoft Teams User Feedback Forum:

1

OS-Native Teams Notifications can be enabled even if your organization disabled beta access, by modifying the settings request with a proxy software such as Charles or Proxyman.

I found the following instructions on the macOS UserVoice ticket mentioned above:

Instructions:

  1. Install and open Proxyman
  2. Select "certificate > install certificate on this mac" from the menu and follow the steps
  3. enable https response for teams.microsoft.com
  4. option-click on teams.microsoft.com > tools > scripting
  5. create new script for https://teams.microsoft.com/package/desktopclient/settings/osx with the following onResponse function:
function onResponse(context, url, request, response) {
    
    // Update Body
    var body = response.body;
    body["settings"]["enableNativeNotification"] = true;
    body["settings"]["enableMacNativeNotification"] = true;
    response.body = body;
    
    // Done
    return response;
} 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.