0

I am not able to start any newly installed WSL2 machines, not sure what the exact problem is on my Windows 10 build. I was using Ubuntu 18.04 till yesterday, but then thought to install new version of WSL2 to use its features, hence uninstalled the previous version of it and installed new one. Tried all solutions from the internet and youtube as well, but nothing worked and since then I am getting this error:

enter image description here

I have all the required features enabled such as Virtualization, Hyper-V and rest.

Here is my system configuration:

Edition Windows 10 Pro Version 20H2 Installed on ‎12/‎13/‎2019 OS build 19042.450 Experience Windows Feature Experience Pack 120.2212.31.0

Virtualization: Enabled

enter image description here

enter image description here

enter image description here

My Current WSL1 Machines are working fine. I ran all commands to run WSL2 but still facing the issue.

enter image description here

2
  • Your screenshot does not indicate if Virtual Machine Platform is enabled. Please edit your question to include which optional Windows Features are installed. 0x80370102 is directly linked to Hardware Virtualization not being enabled. We need more information to help you
    – Ramhound
    Aug 27 '20 at 9:54
  • Please provide the output of Get-WindowsOptionalFeature -Online -FeatureName VirtualMachinePlatform
    – Ramhound
    Aug 27 '20 at 10:11
0

The Windows 10 Update Resolved that issue. It was an Issue in Windows 10 Insider Release.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.