0

I have been using TortoiseSVN for a 2-3 months to control my subversion. Today when I tried to commit files to a repository it showed me a strange message like this:

alt text http://lh4.ggpht.com/_DK4gO8ys6jI/TCoFlCXZ8JI/AAAAAAAABoc/fl9q2aWPjY0/error_msg2.PNG

When I went to the menu and selected Cleanup command it showed me this new message box:

alt text http://lh4.ggpht.com/_DK4gO8ys6jI/TCoEws1XFDI/AAAAAAAABoY/osZwXhAXMJA/error_msg.PNG


I have tried to release lock it says that there is nothing to unlock.
What happened with my subversion repository? Has anybody met with this problem before? How to solve it?
A lot of thanks.

  • 1
    Your repository is probably fine, it's your working copy that has problems. – Joey Jun 29 '10 at 15:00
  • Broke images. Title doesn't help to understand the question. – Michel Ayres Apr 23 '14 at 11:31
1

Delete the working directory (or backup it, if you already did changes). Then, get new a copy from the server (and merge your changes from the backup copy with tool like WinMerge)

1

Asked and answered on stackoverflow.
https://stackoverflow.com/questions/127932/svn-working-copy-xxx-locked-and-cleanup-failed

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.