0

I am currently running nwipe on a brand new external USB hard drive, using the default setting if DoD Short. The hard drive is brand new, USB 3.0, and 5TB in size.

When it started 14 Hours ago, the throughput was somewhere around 120 MB/s, with the estimated time around 48 hours. Since then, the throughput has dropped down to 62 MB/s, and the time remaining keeps increasing (due to the throughput slowly decreasing).

I have not been able to find any estimates to help determine whether this seems correct, or if it is going slowly. Does this throughput seem correct for a USB 3.0 external hard drive?

I understand DoD Short is overkill, but I did a single pass of dd /dev/zero, but when I opened the drive in xxd, there was non-zero data at the very end of the drive! So now I want to be sure everything is off of there.

Thanks

2
  • That drive seems slow. My guess is that drive is a cheap one preferring energy efficiency over speed. Generally the earlier (outer) tracks are significantly faster then inner tracks, and anecdotally I'd say a 50% slowdown is not uncommon - but I'd have hoped for more then 65 megabytes/sec average - although this is not "beyond acceptable" level. Out of curiosity, what is the point of wiping a new drive (save for as part of full drive encryption). Also, why would nwipe be better the dd?
    – davidgo
    Sep 2, 2020 at 5:36
  • Thanks for the input. The drive was used on the day it was purchased, so it did have some data on it, I am not wiping a blank drive :) I don't think nwipe should be better than dd, but when I did a dd with zeroes, I read the drive raw data and saw a bunch of non-zero data on it. Some non-zero at the beginning seemed ok, maybe protected sectors or something. But at the end of the drive was a bunch of non-zero data, had me concerned. Sep 2, 2020 at 12:54

1 Answer 1

0

To try to answer this for anyone who stumbles on it in the future, it took 72:04:13 for nwipe to run DoD short on a 5 TB drive. The write speeds fluctuated during the process up and down between approximately 120 MB/s and 60 MB/s for a brand new USB 3.0 external Western Digital MyPassport.

The final screen showed a final speed as 121MB/s, but I don’t know if that was a cumulative total, or just the speed at the end.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .