0

Certain websites seem to have been able to override Google Chrome's "Mute site" setting.

This is apparent if you follow the below procedure to perform a clean test:

  1. Go to Chrome sound settings (chrome://settings/content/sound).
  2. Flip the switch to show "Mute sites that play sound".
  3. Make sure the Mute and Allow lists don't contain youtube.com or duolingo.com.
  4. Try playing a random video on youtube.com, followed by starting a random lesson on duolingo.com (which, by the way, does not require an account).

Both websites will appear to be muted when audio plays (icon with crossed speaker shown in right side of tab and address bar), but only the video on youtube will actually play muted, while the duolingo lesson will announce foreign words when you click on them and read foreign language sentences out loud as they appear on screen.

Duolingo.com is the only example I know of so far, but whatever they are doing to override this setting, other websites could potentially be doing as well.

Does anyone know what it is that allows e.g. duolingo.com to override this setting?

Or at least how to enforce the Google Chrome "Mute site" setting for e.g. duolingo.com (please assume that my use case requires e.g. duolingo.com to be muted, while other websites continue to play sound)?


Additional info: Right-clicking on the e.g. duolingo.com tab and choosing "Unmute site", followed by another right-click to choose "Mute site" will actually result in muting the website. But only until the next time you load the website.

0

It is probably a problem with your chrome browser itself - I mainly use Firefox and tested YouTube and Duolingo and both successfully muted on the first try. I also tried it with Chrome and had no issues either, so I'd suggest trying a clean install or checking it is up to date.

Also what version of chrome are you using? I just opened it for the first time in ages, so I probably have an old version - it would be helpful if you could tell me your version.

I wouldn't say Duolingo or other sites would be purposely exploiting or overriding this setting on your Chrome, but perhaps if it isn't a bug it's because of how the two sites may work differently.

| improve this answer | |
  • 1
    Your guess about Duolingo is a stretch. The browser isn't detecting whether a website is playing a sound - the browser is playing the sound at website's request. – gronostaj Sep 4 at 6:30
  • Ah right - thanks for letting me know, like I said before I wasn't 100% sure - it seems to just be a problem with his browser – pigeonburger Sep 4 at 7:15
  • Thank you for your response. My Google Chrome browser reports being up to date at version 85.0.4183.83. If you want, you could update to this version and see if you can recreate my issue. If not, I will be trying a clean install and possibly trying to get a hold of a different machine entirely to test this on. But please let me know if you have the opportunity to update to this version and check it out. – Nikolaj Sep 5 at 8:35
  • Hi - I am still not experiencing the same problem, so I would definitely try a clean install and see if it persists. – pigeonburger Sep 7 at 22:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.