3

As the title suggests, how can I improve input latency over a remote desktop connection in certain applications? I use a lot of 3D applications (Blender, Unity, Unreal) that involve clicking and holding the middle mouse button and dragging around to orbit around a scene. On a local desktop, there's no problem, but when doing this over Windows RDP I will get a really nasty delay that makes everything on screen become super sluggish. This is extremely annoying and I often end up overshooting a movement like that.

This problem can also be seen on other remote desktop interfaces such as VNC or Team Viewer.

Please let me know how this problem can be resolved! Thank you!

[UPDATE]: To clarify what I mean, here's a discussion regarding the Unreal Engine. I'm still having issues though with other applications.

4
  • How fast is your connection over the remote system. Slower connection speed can cause mouse delays as you describe.
    – John
    Sep 5, 2020 at 1:06
  • The connection speed is fine on my end and the remote system is on fiber. Literally everything works on it (even watching videos over the connection work with minimal lag), but as soon as I try doing something in a 3D program with dragging the screen, it gets all wonky
    – Microbob
    Sep 5, 2020 at 1:09
  • Is the 3D data like a database? Client Server does not work well over a remote connection and for databases, can result in damage. Try accessing the computer at the other end and running the 3D program (and data) on the remote computer. That may improve things.
    – John
    Sep 5, 2020 at 1:18
  • I made an edit to the post which hopefully will clarify things 👍
    – Microbob
    Sep 5, 2020 at 15:45

1 Answer 1

7

After some more digging, I came across this forum post for the Unreal Engine. The information shared is applicable for all RDP usage.

Here's my paraphrase of the post:

  1. On the host PC, Open "Edit Group Policy" (search for gpedit in the Start search bar)
  2. Browse to: Local Computer Policy\Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment
  3. Enable "Use the hardware default graphics adapter for all Remote Desktop Services sessions" (right-click > edit > enabled)
  4. Enable "Configure H.264/AVC hardware encoding for Remote Desktop Connections" (forum post says this is optional, but I think any acceleration is welcomed if you have the hardware to support it)
  5. Restart the RDP connection (if necessary)
  6. (Something extra I found): Change RDP color depth to 24-bit (in RDP display settings before you connect), if your work doesn't require 32-bit color depth.

I immediately saw significant improvement in input lag when running 3D applications with these options on.

1
  • Also improved here. Thanks! Sep 30, 2021 at 2:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.