3

Whenever I search for a single-word term in Google via the Chrome omnibox, Chrome presents a suggestion to instead visit that term as an http://-prefixed "URL":


Did you mean to go to ?

Did you mean to go to http://some-random-google-search/?


I've never seen this behavior from Chrome before, and it's quite annoying when searching. The pop-up banner is often delayed by 1-5 seconds and comes in well after the SERP has loaded.

I've only noticed this today when using my iPhone's Personal Hotspot tethered to my laptop.


Why is this banner being displayed by Chrome? Can I prevent the browser from displaying it for obviously non-URLs?

1 Answer 1

3

Can I prevent the browser from displaying it for obviously non-URLs?

  1. On your address bar, type chrome://flags.

  2. On the search box type: #enable-lookalike-url-navigation-suggestions

  3. Set it to Disable, then relaunch Chrome. The suggestions will stop appearing.

enter image description here

Why is this banner being displayed by Chrome?

The explanation for this banner is extracted from the article sourced below:

The Google Chrome browser is set to add a feature that will warn users when accessing sites with domain names that look like authentic websites.

The feature has been in the works for quite some time at Google and is a response to the practice of using typosquatted domains or IDN homograph attacks to lure users on websites they didn't intend to access.

For example, crooks often register misspelled versions of popular domains, such as paypall.com, or they'd use domains with Unicode characters like coịnbạse.com to host phishing pages and steal users' credentials.

Source: Google Chrome to get warnings for 'lookalike URLs'

6
  • Good answer for the fix. Can anyone give an explanation for why this is suddenly happening? DNS-related, I believe.
    – pkamb
    Sep 8, 2020 at 17:36
  • @pkamb See edit. Sep 8, 2020 at 17:50
  • 3
    no such flag exists in Version 87.0.4280.88
    – Nando
    Dec 28, 2020 at 16:29
  • @BuddyZ superuser.com/a/1612429/855367 Dec 28, 2020 at 16:30
  • appreciate the link Reddy. That let me access the flag, but unfortunately changing the enable-lookalike-url-navigation-suggestions still didn't have an effect on the browsing experience. Even after a restart, I still get the "did you mean to go to"
    – Nando
    Dec 28, 2020 at 23:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.