2

I have a ThinkPad T490 and an Ultra Docking Station. My external monitors connected to the dock via DisplayPort are not working properly.

My goal is to properly use two external monitors on my T490.

The symptoms are as follows:

  • Both external monitors are detected, but only one can be used/addressed by the system (if at all; read further)
  • The external monitor starts to turn off and on frequently by itself
  • The external monitor displays some kind of green background noise
  • The external monitor is not detecting any input and just turns black (this happens most of the time)
  • The entire laptop freezes completely when changing the display resolution

These symptoms happen randomly. It is not possible to describe exactly when the problem occurs.

My system is the following:

  • Docking station: ThinkPad Ultra Docking Station
    • Model: 40AJ
    • Firmware: up to date; updated with v3.3.1 fw updater
  • Laptop: ThinkPad T490
    • Model: 20N3
    • Firmware: up to date; BIOS v1.69, Thunderbolt fw 1.1.11.18-N2ITF13W
    • OS: Manjaro Linux (up to date, Kernel 5.8.x)
    • Connected to the docking station
  • Monitors: 2x Dell U2518D
    • Connected to the docking station via DisplayPort
      • The same issues occur when I use the HDMI port on the docking station, so it doesn't matter if it's DisplayPort or not

The Linux system seems not to be the problem. I face the exact same issues when I boot into Windows 10, so I guess this has to be an hardware or (BIOS) configuration issue.

  • If I attach an older T480 (running Linux Mint) to the same docking station and monitors, it works flawlessly.
  • If I attach a newer T14 (running Manjaro as well) to the same docking station and monitors, it works flawlessly.

The HDMI port on the laptop itself (no docking station) works perfectly, but only allows me to use one external monitor. The USB hub on the docking station works as well - only the display outputs are not working.

What I've tried to fix this issue:

  • Updating the docking station, BIOS and Thunderbold firmware
  • Using Windows instead of Linux
  • Connecting only one external monitor
  • Using the HDMI port on the docking station

I don't know what to do here. Can anyone give me a hint to achieve my goal or to solve the problem?

1

Ok, I found comments on lenovo site to try the following fix, do a full power down reboot - from with the bios, so all is forgot:

  1. Take any external battery off.
  2. boot into bios page (press enter at lenovo icon), and set internal battery power off also (look for it). Once saved, laptop turns off. But all comes back on, on next reboot.

This did work. All ports on the laptop and through dock are now happy and working again.

Had one 4k monitor using the display port flash on/off a few times every hour. But some other bios option about when laptop should check and discover pluged in monitor info solved at.

I found this because my laptop was also ignoring the plugged in power pack and not charging correct at full power. I have two usb-c chargers, same voltage, one is much lower wattage than the default lenovo. Once smaller charger plugged in, i got boot time warning - and from that point on Laptop would not recognize bigger charger was in use. Not until bios power off, apperantly once an issue occured it was remembered - and not forgot until full power down.

Maybe this helps. Experiment.

1
  • This worked for me on a similar issue, almost went nuts after reinstalling display drivers and trying different cables for an hour with no success. A simple power off/on worked though, thanks a bunch! :) – Sune Rievers Apr 6 at 23:20
0

Same issue. No idea how to fix the 40AJ dock, but I did figure out how to dock 2 monitors direct on the T490 (or T480).

Laptop has one obvious hdmi port (right side), and 2 USB-C's ports (left side). One is for power (back one), lock close, there is another just in front of that (not normal looking) - it will support a UsbC-to- dongle (main UsbC will not, not for me - dongles ignored).

I tried using the second UsbC with UsbC-to-VGA and a Usbc-to-HDMI dongles. Both worked. So with the normal HDMI port, and the dongle - that givies me 2 external monitors and main laptop screen. A lot of wires, but working.

Kinda mad an expensive dock has no other solution but to sit and gather dust now, no value. Hit my dock and several others at the same time this week. No idea what updated.

1
  • I have the same issue on a T14s. All drivers up to date. I believe it could be some power related issue through the Thunderbolt 3 USB-C port. The dots on the display appearing as noise is annoying – Rajesh Shashi Kumar Dec 15 '20 at 15:22
0

The problem seems to be on the docking station.

Because I have two Type-C hubs different brands. Laptop Thinkpad E495 (Linux Mint). AOC monitors 24 inch HDMI same model 2nos. One in office & one in home.

Office dock is working smoothly, home dock is making trouble all the time. Everytime I needed to restart the laptop 4-5 times to detect the external monitor.

Hope it helps someone!

0

There is a bug in the chipset used by Thinkpad docks for external monitors connected to the dock - which I think exhibited in the USB-C and TB3 docks. Mine is a TB3 dock, so at least I can confirm the issue in that one and confirmed by Lenovo. You can read my read up on this here.

0

Finally discovered the issue documented here by Lenovo: https://support.lenovo.com/ca/en/solutions/ht508988

Evidently there are firmware updates for most systems available here:

Linix https://fwupd.org/lvfs/search?value=thinkpad+thunderbolt+firmware

Windows https://pcsupport.lenovo.com/ca/en/solutions/ht508988?clickid=XTp1ISU%3ATxyLW8XwUx0Mo36KUkEXh4WBwykaXE0&irgwc=1&PID=221109&acid=ww%3Aaffiliate%3Abv0as6

However as stated by Lenovo, these updates are still in the review process.

1
  • I can confirm that both the Ultra Docking Station and the T490 have firmware updates. On loading those in, it made a huge difference in the responsiveness of the external monitors. – bridgesense Mar 27 at 14:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.