5

I'm doing a search for a term "BasePlugins" in a directory using the "Find in Files" feature of Notepad++. If I use Windows XP's search function in this directory, it will find several HTML files with the term "BasePlugins" inside. However, Notepad++ did not find these instances of the term "BasePlugins" in these HTML files, is there a reason for this? I had it set to not care about matching case and to search subfolders, but it still wouldn't find the HTML files...

migrated from stackoverflow.com Jun 30 '10 at 2:25

This question came from our site for professional and enthusiast programmers.

  • belongs in super user :), maybe you will have more luck there, i know i did – Prozaker Jun 30 '10 at 2:17
6

Not really a developer question.

I just tried it on my notepad++ 5.6.8(unicode). Works fine.

Just remember to check the checkbox for in all-subfolders. Also remember to point the directory into the right place. I also put *.* in the filter field.

  • Beat me to it. I was also going to add that he should try unticking the "match case" and "match whole word only" boxes, if he's still not finding anything... – otherchirps Jun 30 '10 at 2:22
1

Thanks Kyle that's exactly it! It says "Press Enter" to cancel, but I didn't realize hitting "OK" would cancel it...I think I hit "OK" thinking I should hit "OK" to see the results of the search (since there's no progress bar I didn't know the search was ongoing, it was taking a long time).

1

I found that the results where shown in a window which was minimized. draging the bar solved the issue. Before dragging the bar this is what it saw: Before dragging bar Afterwards a list of results where visible: After dragging bar

0

I couldn't comment on my original question above as I wasn't registered when I wrote it, and I don't have enough points to comment on the above answers, so I have to post these follow-up details as an answer...

If I use "Find in Files," with "in all sub-folders" selected, and with the "match whole word" and "match case" boxes unchecked, and I search for the term "baseplugin" in the path

C:\Program Files\ElectroServer_4_0_6\documentation\server\extension,

I get the result "24 hits in 6 files." However if I do the same exact thing for the path C:\Program Files\ElectroServer_4_0_6\documentation, I get the result "0 hits in 0 files."

Am I missing something? I figured with "In all sub-folders" checked, the results would be the same whether I was searching C:\Program Files\ElectroServer_4_0_6\documentation\server\extension or C:\Program Files\ElectroServer_4_0_6\documentation

The folder structure and contents I am searching come from: https://www.electro-server.com/downloads/builds/ElectroServer_4_0_6_Windows.exe. Thanks for any insight into why this is happening/if I'm missing something, thanks...

  • "whole word" checkbox you tried helped me. – Noumenon Sep 10 '17 at 16:34
0

1 - Uninstall Notepad++

2 - Reinstall Notepad++ and CHECK "DON'T USE %APPDATA%"

This has worked for me.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.