After substituting Docker Desktop on Windows 10 with a more recent version, clicked to start it and got the following error

WSL 2 installation is incomplete

WSL 2 installation is incomplete

The WSL 2 Linux kernel is now installed using a separate MSI update package. Please click the link and follow the instructions to install the kernel update:


Press restart after installing the Linux kernel

By default, in Settings > General the option "Use the WSL 2 based engine" was already selected. This might be due to me already having Ubuntu 18.04 LTS locally.

If I go to Docker Desktop Settings > Resources > WSL INTEGRATION

Docker WSL Integration

You don't have any WSL 2 distro. Please convert a WSL 1 distro to WSL 2, or install a new distro and it will appear here.

How can I get Docker running?

3 Answers 3


There's two ways you can get it to work

  1. Using WSL 2 based engine.
  2. Without using WSL 2 based engine.

1 - Using WSL 2 based engine

In this page under "Download the Linux kernel update package".

Update Linux kernal package

and then Docker will start just fine

Docker running

2 - Without using WSL 2 based engine

If the goal is just to get Docker running, one can simply start by unchecking the box that says "Use the WSL 2 based engine". This can give the following error

Required Windows feature(s) not enabled: Hyper-V.

Required Windows feature(s) not enabled: Hyper-V.

Switch to WSL 2 based engine?

To enable Hyper-V: https://docs.microsoft.com/en-us/virtualization/hyper-v-on-windows/quick-start/enable-hyper-v

So, in PowerShell 7 run the command

Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V -All

Hyper-V in Windows 10

which requires to Restart the computer to complete the operation. Then, once starting Docker again, you can get the following error

Docker failed to initialize

Docker failed to initialize

One or more errors occurred.

Eventually, just by clicking to start again, Docker will start running

Docker running

docker version

  • 2
    I had already installed WSL on my Windows 10 box. So, the 1st suggestion worked for me, after a restart post installation without any hassles. Thank you.
    – itsraghz
    Oct 24, 2021 at 8:18
  • Excellent answer to the question but I will say, take a peek at Arun's answer as well, FIRST. This did resolve things for me quickly and easily. Jan 20, 2023 at 14:34

I had the same error. I just had to update WSL by executing:

wsl --update

Follow guide at this link.

You need to enable the windows subsystem for linux with command:

dism.exe /online /enable-feature /featurename:Microsoft-Windows-Subsystem-Linux /all /norestart

which enables WSL1.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .