0

I am trying to connect 16 DB kingston data traveller to my Ubuntu machine. This pendrive is not being detected in other machines. Thats why I tried to check it. When I issue a lsblk command, I am getting the below output. enter image description here

Its showing /dev/sdc only/ /dev/sdc1 is not there. I think the partition is missing. I tried to format it using GParted, but the format option is disabled for this drive.

Is it hardware issue or something which can be corrected?

lsblk -f shows the following output.

enter image description here

sudo blkid -c /dev/null is showing as below.

enter image description here

I have tried to create new partition using fdisk also. But its giving me read only error.

enter image description here

  • Could you show what lsblk -f and sudo blkid -c /dev/null list for sdc? – user1686 Sep 16 at 7:00
  • Try creating a partition for it with fdisk? – davidgo Sep 16 at 7:48
  • @user1686, I have added the results for the commands that you mentioned. Please check. – Jyothish Bhaskaran Sep 16 at 8:21
  • 2
    Please don't post images of text. Reasons are listed on our sister site: here. – Kamil Maciorowski Sep 16 at 8:24
  • 2
    Please read the error message again: It’s not about permissions at all. Also, get a new flash drive, this one is done. – Daniel B Sep 16 at 8:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.