1

during yum update on one of our rhel 7.6 server we get the following error

--> Finished Dependency Resolution
Error: Package: libtirpc-devel-0.2.4-0.6.el7.x86_64 (installed)
           Requires: libtirpc = 0.2.4-0.6.el7
           Removing: libtirpc-0.2.4-0.6.el7.x86_64 (@anaconda/7.2)
               libtirpc = 0.2.4-0.6.el7
           Updated By: libtirpc-0.2.4-0.15.el7.x86_64 (uaans75-repo)
               libtirpc = 0.2.4-0.15.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

the are two solution for this problem

first solution is to exclude the problematic rpm as

 yum update --exclude=libtirpc --exclude=rpcbind --exclude=nfs-utils

or to use the skip-broken

 yum update --skip-broken

about the first suggestion , I think we can install the non update rpm after yum update

so my question is

what is the preferred solution ? ( exclude rpm or to use skip broken ? )

0

--skip-broken will skip all unresolved dependencies. Meanwhile --exclude will exclude a specific package from being updated. The problem here is that you don't have the correct dependency for the package libtirpc-devel.

Try to find the correct repository.

But if you don't bother installing this package I suggest to use --exclude as long as you will be controlling what you are doing and avoiding packages conflict.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.