4

Amongst other problems, upon upgrading to Thunderbird 78, it now fails to connect to my personal e-mail account. My personal e-mail account is Exchange-based -- I have no control over that -- but it worked just fine as a regular IMAP account in Thunderbird 68 and on my phone, for example. Has anyone else had any luck with this?

  • I've had some success using DavMail as a local proxy, but I'd like to avoid this if possible. – Xophmeister Sep 18 '20 at 13:07
6

Thunderbird 78 now uses the same default settings like Firefox for TLS connections: Only TLS 1.2+ is allowed by default.

If your Exchange server is a bit older and only support up to TLS 1.1 then Thunderbird is unable to connect to the IMAP server.

The way to make Thunderbird connect again to that server is to allow TLS 1.0/1.1 again by setting the Thunderbird configuration entry

security.tls.version.min = 1 
  • 1 = TLS 1.0-1.3 allowed
  • 2 = TLS 1.1-1.3 allowed
  • 3 = TLS 1.2-1.3 allowed (new default value since Thunderbird 78)

Mozilla documentation on security.tls.version

Addendum: Note that because the SMTP server is part of Windows and not of Exchange, TLS1.2 on SMTP is usually supported (SMTP uses the TLS library of Windows but Exchange has it's own TLS libraries which are older).

  • Thank you: That did the trick :) – Xophmeister Sep 18 '20 at 13:58
  • Thanks for your sharing. – Jeff Yang7 Sep 21 '20 at 8:28
  • To change this in version 78. Click on the menu icon (3 bars) > Options > Type "about:config" into the search box and click on "Config Editor". Accept the risk and filter for "security.tls.version.min". Then change the min version from 3 to 1 as stated above. – Navigatron Nov 6 '20 at 12:48
  • Of course, this is not secure. If you have a way to fix the server to support TLS v1.2, it would be a lot better! – Alexis Wilke Nov 8 '20 at 17:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.