0

I have a Lenovo Yoga 2 laptop running Windows 10 Home (build 19041). Almost always I have its lid closed and use an external monitor + keyboard + mouse instead.

My problem is that its touchpad (Device Settings say it is 'Synaptics ClickPad V8.1 on PS/2 Port') is over-sensitive and detects false touches when the laptop lid is closed. So I want to have it disabled 99% of time.

There is FN+F6 key combination to do it. However, occasionally it enables again all by itself and it is cumbersome to have to open the lid and press the key combination.

I have already searched tons of forums suggesting remedies that do not work for me, e.g.:

  • Disable the touchpad via Device Settings (either via Control Panel or via tray icon) - There is no such option on my laptop. (And even if there was, it is too many clicks, if you need to do it several times a day.)

  • Disable touchpad when another mouse is plugged in - This is a vendor-specific option unavailable on my laptop.

  • Disable the device - Again unavailable on my laptop: On the Driver tab of Lenovo Pointing Device Properties I can 'Update Driver', 'Roll Back Driver', 'Uninstall Device', but the 'Disable Device' option is always grayed out. (And again even if this worked, it is too many clicks.)

  • Disable the touchpad completely in UEFI - There is no such option on my laptop.

To sum it up, the FN+F6 is the only way I have found so far, but it is very user unfriendly when I keep my laptop lid closed all the time.

So, I am trying to find another way to do disable my touchpad. Preferably a shortcut to a script I can place on desktop (and run on start-up). Or another key combination I can type on my external keyboard (that is, without the FN key).

2
  • If you type "Device Manager" into the Start menu and open that, is the touchpad listed in there? If so can you disable it there? Sep 18, 2020 at 13:41
  • @TeddyTedTed There is "Lenovo Pointing Device" in Device Manager > Mice and other pointing devices. It represents my touchpad and as I wrote in my question, it cannot be disabled there (the option is grayed out).
    – Ľubomír
    Sep 18, 2020 at 13:54

1 Answer 1

1

Open Control Panel, Mouse. Then ThinkPad tab (or appropriate tab).

Disable TouchPad there - Uncheck it.

You can do this from the OS with the Lid closed.

I use this to disable my own TouchPad.

Also make sure all your drivers are up to date. Lenovo Software Update App (which should also be in Control Panel).

You can consider a USB Mouse to use as your default mouse and then (after updating the drivers) move sensitivity on all settings to the lowest (least sensitive) level. You can do that.

2
  • I don't have this 'disable' option there at all. I wrote it in my question.
    – Ľubomír
    Sep 18, 2020 at 13:57
  • I amended my answer to add extra steps.
    – John
    Sep 18, 2020 at 14:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.